Getting player to show full player Moodle

Posted Thursday, October 27, 2011 at 6:54 AM  

Hi

 

Has anyone resolved the issue of getting the Articulate player to show in Moodle 2. When my Scorm packages launch in Moodle window only shows part of the player.

 

Regards 

 

Richard


All Replies

Louise Hawkins

82 posts

Posted Thursday, October 27, 2011 at 8:54 AM  

Hi Richard,

 

Please could you provide a screengrab of what you're seeing?

 

Thanks,

Louise


Posted Thursday, October 27, 2011 at 9:11 AM  

Hi Louise

 

This is what I'm seeing. Part of the player is cut off as are the controls and this makes it difficult for new users.


Dave Newgass

456 posts

Posted Thursday, October 27, 2011 at 9:31 AM  

Hey Richard,

 

What settings do you have for the 'Display Package'?  Have you tried to set it up to open in a new window?

 

Have you explored the 'Full Screen' hack for Articulate?  It saved my tail in that if I couldn't go full screen, Articulate was a no go.

 

I am hoping the new updated Studio will have this already built in!  (please Articulate....PLEASE!)

 

Let me know your thoughts...

 

Cheers,

Dave

 

 


Art Help1.jpg

Posted Thursday, October 27, 2011 at 9:59 AM  

Thanks Dave, I've tried open in a new window in the Moodle settings and that seems to work but most of our trial users have pop ups blocked on their PCs so it's another barrier for them getting into the course and not ideal.

 

What's the Full Screen hack for Articulate?

 

Regards

 

Richard


Posted Thursday, October 27, 2011 at 10:14 AM  

Has anyone experience of using Scorm Cloud to overcome this type of  issue?

 

Regards

 

Richard


Dave Newgass

456 posts

Posted Thursday, October 27, 2011 at 11:17 AM  

Hey Richard,

 

I like SCORM Cloud.....as a matter of fact, if I could I would switch all of my courses there.  The reporting is fab for SCORM.

 

The reason I haven't is because with our courses, they are broken down into many elements.  We sell our courses and I have not figued out if they can have a whole course made up of multiple SCO's.  We also have the ability for people to buy online and get immediate access.....if they could do all of that, I would switch is a flat second!

 

Please keep us posted....I will contribute when I can.  BTW, have you tried the Moodle Forums (SCORM sub section)?

 

Cheers,

 

Dave

 


Dan Marsden

234 posts

Posted Thursday, October 27, 2011 at 2:13 PM  

there's about 40px of wasted space above the player at the moment in 2.X - I've got a patch here that tidies it up a little bit for both using new window and current window:
http://tracker.moodle.org/browse/MDL-29965

 

but as mentioned by Dave - you can use the "new window" option in Moodle and it will remove blocks/headers/footers and give you more space to work with.

 

A message is also displayed on the page that "launches" the pop-up to tell users who have pop-ups blocked they will need to allow them.

 

and... I just realised we can now add back the link on that page to allow the user to manually initiate the pop-up - at the moment it just displays a message telling the user to enable them but we can now add a link to the page to allow the user to initiate it manually. - see:

http://tracker.moodle.org/browse/MDL-29975


Dave Newgass

456 posts

Posted Friday, October 28, 2011 at 5:51 AM  


Hey Dan,

 

Last week we updated our Moodle site to 2.1.2.  Are the above mentioned trackers still a concern with that version?  How do I communicate to our Moodle host (Remote-Learner, formerly Pteppic) that I need this changed/fixed?  What terms or buzz words do I need to convey?

 

Many thanks!,

 

Dave

 


Posted Friday, October 28, 2011 at 7:20 AM  

Any thoughts on the best settings to use here when publsihing for Moodle....  I've been using resize browser to optimal and lock to optimal. Do these carry through to Moodle?

 

 


Dave Newgass

456 posts

Posted Friday, October 28, 2011 at 1:17 PM  

 

Richard Sharples said:

 

What's the Full Screen hack for Articulate?



 

Hey Richard,

 

Here is a post from the old forum that goes over this....

 

WIth that being said, you can then go to eLearning Enhanced and take a look at the 'Tab Pre-Loader'...this solves the problem of the Full Screen tab not loading in the first instance.

 

@JamesKingsley is the man for this kind of stuff....check out his profile.  He is the heavy hitter at eLearning Enhanced.

 

Here are the settings I have in my template......not sure if that helps or not!

 

 

Cheers,

 

Dave

 

 


Dan Marsden

234 posts

Posted Friday, October 28, 2011 at 7:07 PM  

Dave - neither of the bugs I linked above have been fixed in core yet - I created the 2nd one in the tracker when I was writing the post above - The first one has a patch that you could ask Remote-Learner to apply for you - but it might be better for you to wait a week or so for me to push the fixes into the latest releases - then you just need to ask Remote-learner to update to the latest release rather than asking for a specific patch to be applied.


Dave Newgass

456 posts

Posted Saturday, October 29, 2011 at 12:30 PM  

Hey Dan,

 

Any chance on posting when you have that ready....or is there a way to keep track of that from the Moodle forum?

 

Cheers Dan!


Dan Marsden

234 posts

Posted Saturday, October 29, 2011 at 4:26 PM  

If you login to the tracker you can add yourself as a "watcher" to the bug - that way you get e-mail notifications when comments/status chagnes etc are made. I've submitted the first one for integration already - hopefully it should make it into next weeks build.


Dave Newgass

456 posts

Posted Sunday, October 30, 2011 at 12:09 PM  

Hey Richard,

 

I found this for you.....

 

A SCREENR that James made some time ago regarding using the Full Screen hack.....

 

Good Luck,

 

Dave


Lorenz T

4 posts

Posted Tuesday, January 31, 2012 at 3:11 AM  

Hi Dave,

 

The Full screen hack resolve many problems with Moodle. I used it last year, but i saw that sometimes Articulate doesn't load the tab. I read that you solve the problem using Tab preloader. Can you explain a little more? How can i test the solution?

 

Thanks

 

Lorenz


Dave Newgass

456 posts

Posted Tuesday, January 31, 2012 at 3:20 AM  

Hello Lorenz,

 

Let me tell you....if it were not for the Full Screen ability via this small 'hack', I would have not used Articulate.  I ran into the same problems of not having the tab load.  As a temporary solution, I was advising students to refresh their browsers once they loaded the course.  This was not a great solution....but it did work.

 

In the meantime, I went back to eLearning Enhanced and asked James for some help.  He advised me about the 'Tab Pre-Loader'.  Although I don't know exaclty how it works (James, if you could assist), I do know that it works flawlessly!

 

Here is a link to eLearning Enchanced page that has the information.  Yes...it costs $100 but it was worth every penny!

 

I hope that helps a little.  The link will describe how it works.

 

Good luck!

 

Dave

 

 


Mike Hipsher

34 posts

Posted Tuesday, January 31, 2012 at 5:02 AM  

I am having a similar problem with courses published using Taleo.  Being new to Articulate and Taleo I don't know if there's something I should have done in Articulate before publishing to the LMS (Taleo) or if it's the LMS player.  I have not been able to find anything in the Articulate Community to suggest how the template should be set up and Taleo suggested I remove the header in the player to increase space for the presentation, which didn't work.  As you can see from the screen shot, there are scroll bars where there should be none. This is very frustrating to the user.  I'm thinking this is more an issue with Articulate and something I set incorrectly.  I'm open for suggestions. Thanks.

 


Dave Newgass

456 posts

Posted Tuesday, January 31, 2012 at 5:11 AM  

Hey Mike,

 

I'm not familiar with Taleo.....

 

I don't think there are any setting within Articulate that will help though.  You can try to play with the Templates prior to publishing.  Have you ticked the 'launch in a new browser window' option? (See image towards the top of this thread'

 

Is there an option to launch the course in a new window from within Taleo?


Just some thoughts....good luck with this!

 

Cheers,

 

Dave


Mike Hipsher

34 posts

Posted Tuesday, January 31, 2012 at 5:41 AM  

Thanks Dave,  I'll try your suggestion.  FYI:  Taleo recently purchased Learn.com.


Posted Tuesday, January 31, 2012 at 6:45 AM  

 

Lorenz T said:

Hi Dave,

 

The Full screen hack resolve many problems with Moodle. I used it last year, but i saw that sometimes Articulate doesn't load the tab. I read that you solve the problem using Tab preloader. Can you explain a little more? How can i test the solution?

 

Thanks

 

Lorenz



Hi Lorenz;

The issue is caused because Articulate does not wait for the custom tabs to load before displaying the skin. So if the files are large or the connection is slow they don't appear. But they did download to the browser's cache which means they will load much faster the next time; which is why refreshing the page works.  (most of the time)

Our solution adds a bit of code into Articulate so that after the skin has been displayed it runs the functions to load the tabs a second time.

Problem solved! It's what we do

 

James

 

 

 

 


Posted Wednesday, April 09, 2014 at 8:51 AM  

Does anyone have a fix for this? I am running the latest 2.6 Moodle and Articulate 2013 and two things are occuring 1) the scorm player opens full screen horizontally (width) but not vertically when it opens 2) the bottom is cut off in all browsers--how can I resolve this so that the player opens full screen in both dimensions and the content fits fully within the window without scrolling?


Dave Newgass

456 posts

Posted Friday, April 18, 2014 at 5:27 PM  

That's helpful, thank you now I have to adjust course because I can't use a pop-up because the SCORM won't render for students see https://moodle.org/mod/forum/discuss.php?d=251252 

 

So.. I am now opening it up in the existing windows, and my issue is somehow the top portion of the scorm is adding a bunch of whitespace up top--I am saying it is the scorm (not the template / html) because when I right-click on the space I get the adobe stuff, not the "inspect element" stuff. Ideas? Using the latest Moodle.


Posted Friday, April 18, 2014 at 5:48 PM  

Okay I figured the above out, the Admin and Navigation blocks were down the bottom on the scorm player page, I removed them and viola it can be used.  Still not idea as you have to scroll to get the content fully visible but it works.


Terry Wang

61 posts

Posted Saturday, April 19, 2014 at 11:12 AM  

Hi David,

My suggestions:

1. Menu, notes: displayed on the right hand side.

2.  Google Chrome: adjusting browser by percentage

3. Moodle and Presenter: enable new window