Captivate 7

Carrie Eaton

118 posts

Posted Tuesday, June 11, 2013 at 11:50 AM  

I'm building a game in CP7...now I find when I publish it, it won't work in Artiulate.....any help would REALLY  be appreciated!


This post has 0 verified answers

All Replies

Posted Tuesday, June 11, 2013 at 12:05 PM  

Hi Carrie,

 

From what I understand, with Captivate 5 and later you'll have to use a web object for the Captivate content.

 

Have you seen this article already?

Adding Adobe Captivate movies to Articulate Presenter

 

If you are using the web object method and the web object isn't loading, it may be a different issue. Are you viewing the published output locally, by any chance? 

 

If you view a published Studio '09 presentation on your local hard drive or send it to someone else to view on their local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.

 

To properly test your published content and share it with others, upload it to the environment for which it was published. Please review the article below for more information:

Publishing and sharing Studio '09 content

 

Let me know how it goes :)

 

Thanks Carrie!


Carrie Eaton

118 posts

Posted Wednesday, June 12, 2013 at 10:42 AM  

Thanks, so much Christine. The solution in the article worked!

 

But I have one more question. I don't want the playbar to appear in the swf. I can turn it off in the Skin Editor but I see a gray bar across the bottom where the bar would have been. This is probably a question for the CP folks but thought I'd ask, just in case you have come across a quick fix!

 

Really appreciate your help!


Carrie Eaton

118 posts

Posted Wednesday, June 12, 2013 at 10:57 AM  

Found it!

 

FYI...in addition to a choice to SHOW PLAYBACK CONTROL in the skin editor in CP, there's a choice right below it HIDE PLAYBAR IN QUIZ. Unfortunately if you uncheck the SHOW option, the HIDE option is grayed out. BUT if you check SHOW, check HIDE and then uncheck SHOW, HIDE remains checked and the playbar goes away completely!

 

You guys are great....thanks!


Posted Wednesday, June 12, 2013 at 11:07 AM  

Hi Carrie!

 

Fantastic! So happy to hear this worked out for you :D Thanks for sharing that information, as well - hopefully this will come in handy for other community members using Captivate 7 in their projects.

 

I hope you have a wonderful day Carrie!

Christine


Carrie Eaton

118 posts

Posted Wednesday, June 12, 2013 at 12:34 PM  

Well, I may have spoken a bit too soon!!!!????

 

I can insert the CP7 file into a small test Articulate piece, but when I put it into my main project file, I get scripting error messages when I move forward or backward. Strange....any ideas? Should I just chalk it up to some corruption in my file???


Posted Wednesday, June 12, 2013 at 1:29 PM  

Hi Carrie,

 

Honestly, I'm not sure - I don't have Captivate or any way to test this on my side. 

 

What type of scripting errors?

 

Can you try inserting it into a new project?

 

Are you getting the errors when previewing, or after you've published? If you get this while previewing or viewing the published project locally, try uploading it to a server or LMS and see if the same errors pop up.

 

Thanks!


Carrie Eaton

118 posts

Posted Wednesday, June 12, 2013 at 10:07 PM  

Christine, I'm still trying to see a pattern here.Adding the web object to a small, new file seems to work most of the time...but not always. Same for dropping it into the existing course file. The error occurs, it's when I'm moving to the next or previous screen. The first one is "Unable to set value of the property setDriverFinalized.Object is null or undefined. ... Do you want to continue running scripts on this page?"

 

I will be working on this again tomorrow afternoon and will see if I can get a better grip on when the problems are happening.

 

I am publishing to an LMS format which I understand should allow me to test on my local machine.

 

Thanks!


Posted Thursday, June 13, 2013 at 6:55 AM  

Hi Carrie,

 

I think I see what's going on. If the script error is occurring when you;re moving in the presentation, after publishing and viewing it locally, it may be due to a browser restriction. 

 

Again, you'll need to upload to a sever to test the content properly, as I mentioned earlier

 

If for some reason you don't have access to the LMS at this point, you could always upload your course and test it using the Tempshare server, or even SCORM Cloud.

 

Let me know if it works better once you have it on a server.

 

Thanks again Carrie! :)


Carrie Eaton

118 posts

Posted Thursday, June 13, 2013 at 11:36 AM  

Christine, after a bit of testing today, I think it's been 'operator error'! By trying different files (new small files with just three slides, new files with just a few from the course, the course itself) in different places, I believe I wasn't careful about getting the necessary index.html in the correct place.

 

And one of my issues is how SLOW it was to preview, publish, etc. I just looked at the published course and under data there is a webobject_slide38  folder....slide 38 is where the web object is located....that folder is over 4G!?!?! It has all the ppt andppta files from the tests I did. Why is that happening?  Whenever I previewed I saw some of those filenames going by and just now see why. How do I keep those old files out of the published course? Ideas please?

 

Thanks!


Carrie Eaton

118 posts

Posted Thursday, June 13, 2013 at 12:04 PM  

Christine, just saw your post of 4 hours ago....doesn't appear to be related to running local as long as I publish to LMS and get the index.html in place. It works.....other than the HUGE size of the published course?! I've tried removing some of those what-seem-to-be extra files, a few at at time and it continues to work. But then the last time I removed a few, I broke the course, so it's obviously going to be better for me to learn how not to get those written out during the publish than to clear them myself!?


Posted Thursday, June 13, 2013 at 12:21 PM  

Hi Carrie,

 

Really is starting to sound like an installation or corruption issue, honestly - especially if the file is getting that large.

 

Unless the presentation truly contains that much content, there's a problem somewhere.

 

It might be best to go ahead and contact our support team regarding this issue. They'll take a closer look and see what's going on.

 

Articulate Support - Submit a Support Case

 

Please be sure to include a description of your issue. Please also include the URL for this thread in the form. Also, please share the case number with me. You're welcome to do so here, or in a private message. This way I can follow the progress of the case and update this thread.

 

Thank you Carrie!


Carrie Eaton

118 posts

Posted Thursday, June 13, 2013 at 12:29 PM  

I agree. No, the course doesn't contain that much...only 48 screens. Also, I can see those filenames....multiple copies!?

 

Will submit a case and keep you posted. Thanks for your help...............................