Engage '09 interactions not working in Google Chrome

Just recently my interactions no longer work for my courses when accessing them using Google Chrome as the browser (work fine in Internet Explorer).  This just started happening.  When you click on the slide with interaction you just get a "circling" icon, but the interaction never appears.  Anyone experience this?  Is there a solution?  Thanks. 

45 Replies
Jeff Tenut

We build courses in with Presenter using Engage and we also build with straight Adobe Flash. We are having issues with both types of courses built with Engage and Flash only...and the problems didn't start until the February update of Chrome and Flash came out. These courses all work fine on Fire Fox, IE9-11 and many other browsers.. 

Chris Fenwick

I'm debugging a similar issue. In my case, it seems that Engage+Chrome are not working when gzip compression is enabled. If anyone is feeling adventurous they can try this:

  1. Install the ModHeader extension for chrome (https://chrome.google.com/webstore/detail/modheader/idgpnmonknjnojddfkpgkljpfnnfcklj)
  2. modify your accept-encoding header so that it sends nothing (it normally sends a few compression types that chrome will accept). It should look like this:

3. Try your course. 

If this fixes it for you, then you have the same problem as I do. Don't forget to deactivate the request header when you are done (uncheck the box or deactivate the chrome extension).

Meg Fairchild

I just tried Chris' suggestion and it worked! So my next question is...what do we do next because we can't very well ask learners to download this chrome extension. 

Also, I don't know if anyone else has done any testing from a Mac computer, but it appears that the Engage loading issue also happens when viewing the course in the Mac version of Firefox (28.0) as well as in Safari (6.1.2). 

Chris Fenwick

I was hoping that my comment would help Articulate pinpoint the problem, and they can either find a fix, or submit a bug to Adobe. If this is happening on  Safari as well, I think that rules out Chrome as the source.

If anyone needs to reproduce this issue for investigation purposes, and all you have access to is the Scorm cloud, you can run Fiddler (http://www.telerik.com/fiddler) and turn on the "apply GZIP encoding" option. This will produce the same behaviour we are seeing.

Tom  Davenport

It is clearly an issue with Google Chrome.  Seems to work Ok in Internet Explorer.  We are looking at alternative solutions going forward.  We can't run our business waiting for responses through a message board.  Just not an efficient way to do business.  It is obvious that there are others experiencing this issue and Articulate should be able to recreate it pretty easily on their end.  For me to have to send files through an inefficient process and then wait for responses is unacceptable.  I love the product when it works, but it is just to hard to get resolution to issues and to many compatibility issues with browsers to make this a long-term effective tool for us.

Frank Muniz

No big Leslie. Here is a quick update from my buds at Articulate who clued me in to what may have been the issue, in my case:

UPDATE: Ok, so it looked like it was a server-side compression that was making the files un-readable through the web browser. Since hosting it outside of the site, we had to adjust the .htaccess file to handle the compression issue specifically for that file type.

I hope this solves the issue for good. If anything else comes up, ill let you all know.

Carla Frias

Frank Muniz said:

No big Leslie. Here is a quick update from my buds at Articulate who clued me in to what may have been the issue, in my case:

UPDATE: Ok, so it looked like it was a server-side compression that was making the files un-readable through the web browser. Since hosting it outside of the site, we had to adjust the .htaccess file to handle the compression issue specifically for that file type.

I hope this solves the issue for good. If anything else comes up, ill let you all know.

Dear All, I have been having this same problem!

Frank,  could you let me know a bit more information regarding your solution?

Louise H

Hi all, my Chrome updated today to include the new Flash Player version. I'm now on Chrome v 34.0.1847.116 m, and Flash Player is now v 13.0.0.182. Just wondering whether this update has fixed it for anyone?

I can't tell as it's always worked on my Chrome! Would be good to know if there has been any effect though.

Megan Creegan

Seems like the issue has popped up again, but now with Internet Explorer. Recently, Microsoft released a patch to Flash security to address a recent vulnerability, so I'm wondering if anyone else is having the same issue again with Engage 09' interactions that seem to load indefinitely with a constant spinning wheel icon? I'm using IE8, but I have the latest security updates. Everything works fine in Chrome...

Christine Hendrickson

Hi Megan,

I'm afraid I don't have access to Internet Explorer 8 on this machine. Are you able to tell us what version of Flash you're using in IE? It should be a little different than the version that's installed for Google Chrome. 

If you're able to confirm you're running the most recent version of Flash for Internet Explorer, are you able to share a link to your project? I can test this on my end with Internet Explorer 11 and then see if I can find access to an earlier version for testing.

Thanks!