Engage Interaction Display Issue

I have an Engage interaction that was originally created and published in an earlier version of Engage. As part of my troubleshooting I have upgraded the file to Engage 360 and republished. It is a basic FAQ type interaction where the user clicks on an item and it expands to show them the details of that item. There are 10 items in the interaction and they are displayed in a vertical accordion.

The behavior that I am experiencing has now been reproduced both in preview and published to our LMS (LITMOS). My main browser is Chrome (64.0.3282.167 – 64-bit) but I’ve also reproduced similar but not exactly the same behavior in Edge and Firefox. I’m publishing to HTML5 with a Flash fallback. The fact that the behavior is the same in Preview as well as Chrome tells me that Chrome is not launching the HTML5 version of the course but is falling back to Flash.

The behavior is this: when you click through the items, the 8th item contains enough information that a scrollbar appears and you have to scroll down to get to the next item. If you close the 8th item and then open the 9th, then hover your cursor over the final item…it freaks out. In addition if you had scrolled to the bottom of the 8th item, and then click on the 9th to open it, the scroll bar disappears, along with the 1st -4th items in the interaction. You can’t use the mouse to scroll back up to them but you can use keyboard notification.

I’m attaching a video of the behavior both in preview and in Chrome, published in our LMS.

Any thoughts?

12 Replies
Crystal Horn

Hi Matt!  Thanks for the helpful screencast.

I did a quick mockup, and my interaction seemed to work fine both in preview and in published web output.  In the Articulate 360 products, the preview renders in HTML5, so it makes sense to me that you'd see the same behavior in preview as you did in Chrome.

  • Have you already tried deleting the last FAQ question and recreating it? 
  • Can you reproduce this behavior in a new file?

If you're able to share your .intr file here, I'm happy to test it on my end, too!  I might be missing a setting that you customized.

matt thorne

Sorry for the delay getting back to you on this...flu got me.

So...tried deleting the last FAQ question and recreating it, behavior did not change. Then tried creating an entirely new .intr file and creating each question from scratch. Behavior is the same. 

I've attached both .intr files here, as well as a video of the behavior in the new .intr

Ashley Terwilliger

Thanks Matt for sharing both of these Engage files. I took a look at previewing them and published to Articulate 360, and I saw the same thing you described. Here's a link to the examples I published  - FAQ and Ambassador FAQ.

I'm going to share this with my team to take another look, as it may be a possible bug. I'll let you know here as soon as I can. 

I did find that if I had the "Introduction" section enabled, the behavior stopped - so could you look at adding that in for the meantime? You could include some simple directions there about how to click between the individual items.

Ashley Terwilliger

Hi Matt,

I published a version of your Engage interaction again with the Intro tab enabled, and it did stop the flickering for me - but not the scroll element. Can you take a look at this one and let me know how it works for you? 

Also, when you're testing the output and sharing the video where are you testing it? 

matt thorne

Your link doesn't give me the freakout, but i do get the issue with the scroll element.

For me, when it is in our LMS (LITMOS) i'm still getting both behaviors. I just published an new file and uploaded it into a module and get both behaviors in chrome. 

I'm attaching the .zip file that I uploaded to LITMOS.