navigation of engage interaction after first viewing

I would like to set my program to require users to view all screens the first time they complete the program. However, on subsequent passes, or even when they just want to go back to review previous screens while  they are in progress, I would like to give them the freedome to view current and previous screens openly.

I see a setting to do this for Presenter screens. However, for Engage, it looks like I can only pick: Allow user to leave interaction after viewing all steps, or I can pick: Anytime. Is there a way to allow users to leave interactions after viewing all steps on the first pass, and then allow them to leave Anytime on subsequent passes?

14 Replies
Justin Wilcox

The closest you are going to get to that is to allow a user to leave the interaction at anytime and set your player template in Presenter to Restricted. This will mean that the person will have to view the last step of the interaction the first time before they can move on to the next slide. The next time they view the presentation, they won't have to view the last step of the interaction. So not exact but I think most people are not going to just know they can skip to the last step before advancing.

Gwen McLean

If I do this, it does not make the user view the last step of the interaction the first time through, unless I'm doing something wrong. From here, it looks like the user is allowed to just move forward and can skip all the interactions within the engage slide. Can you explain further how you make this work? How putting the setting to "Restricted" in the presenter file will restrict the user from skipping the interactions when they hit an interactive slide the first time?

Gwen McLean

Thank you for sticking with this. I have set the Player Template in Presenter to Restricted. I have tried saving it under the same player template name, as well as saving it to another player template name, and the Presenter files are still not restricted (and neither are the Engage screens -- but they are set at Anytime now).

Another issue is that  even though I have set the settings to provide a pop-up  box to resume where the user  left off, this function is not working either.

Can you offer any more advise on how to get the course to be restricted (and I can keep the Engage screens at Anytime), and getting the resume function to work? I don't know why the settings are not sticking.

Gwen McLean

More on this ... The problem seems to be that even though I have set certain settings in the Player Template, they are not sticking, even when I save the player template under a different name. Do you know what could be causing the player template to not retain changes? When I go back to see if the settings have reverted to something else, it appears that they have not. On screen, all the settings are as I want them to be. However, when I publish the course (and I am publishing for LMS), the Restricted setting and the  Resume setting do not come through to function as I have set them.

Gwen McLean

I found some help online at http://community.articulate.com/forums/p/1170/17393.aspx#17393

It seems to have fixed the problem. I will check and let you know if I still have problems, but I didn't want to you to spend time looking for an answer when I think I found it. Thx.

Posted Wednesday, June 08, 2011 at 2:24 AM  

Suggest answer

Sometimes Articulate has a problem updating old player information with new information. Try this:

1.       Save a new template with all the settings you want if you haven't already done so.

2.       Set this as the course player template and close the menu.

3.       Preview the first slide of the course.

4.       If the template has not been applied, there is a “Player Template” button at the top of the preview. Click this to open the dialog box.

5.       The pop-up that opens should tell you which template is being used. If it’s different than the one you just created, switch to that new template here. Click ok.

6.       Once you click ok, it should instantly apply the new template. If the course is now working properly, close the preview. The old information has been cleared and it will publish and preview in the new template from this point forward.

7.       If you still have a problem, repeat steps 1-4. This time select one of the default templates instead, such as “CorporateCommunications.” Apply this and hit ok. Close the preview window.

8.       Reopen preview and the player template from this view, now apply the new template you want to use in place of the default you selected last time.

Gwen McLean

Just when you  thought it was over ... I need the QM screens to do the same.

 It appears that restricting the Presenter in the player template, does not also restrict the user from getting past the QM screens on the first try. Currently I have set the QM screens to allow the user to leave any time but advance only after attempting the quiz.

Is there a way to make the program require users on their first time through to go through the quizzes (of which there are several interspersed -- not just  at the end), and then be able to skip past the QMs on subsequent times through?

Gwen McLean

Thanks for your help on this. This latest solution worked.

But I have to say, the last time I published the course after I made one more change in the settings, the whole player template got wiped out. Not good. I plan to set it all up again with the custom text labels, etc, and save it under another name. Do you know why the player  template would have gotten wiped out? I understand that these things just happen sometimes, but it would be nice to avoid them if possible.

Gwen McLean

Thank you  again. I do work on my C drive always and try to keep path names as short as possible, but thanks!

I'm sorry to keep asking you questions, but now the resume function will not work. I published for LMS and unticked the cookie box. The course will not prompt to resume on subsequent tries. Even with the cookie box ticked, it will not prompt to resume.

I published to the Web to see if it would make a difference. Still the course will not prompt to resume on subsequent tries. In earlier published versions of this course, the resume function was working properly. Now I cannot get it back to save my life. Please help!

Gwen