Repeatedly getting Unknown Error when I try to publish

This is so frustrating! I have been working on a complex Storyline course about 113 slides that sends variables to the LMS via the instructions posted elsewhere on this forum for passing variable data to the LMS with short answer questions...

I make changes to the file, feel like I am progressing, and then when I try to upload it gives me an "unknown error" message with detailed information to check my account login (I have and it is fine...I can upload other smaller courses).  

Since there are no troubleshooting tools, I am left to shoot in the dark trying to figure what changes I made since the last save that might have caused things to stop working.  

Because I have been having intermittent success getting my output to publish, I have gotten into the habit of saving the last published storyline file in case I need to roll back my changes.  Now, my last published version won't publish.

I am under a deadline and would appreciate some help on this. Also, I have now tried removing the quiz and result slides and publishing without tracking data, and even that won't publish.  

If there any way to trouble shoot this type of problem? I checked my time and timezone--I am synchronizing with an internet time server.  I did notice, when I was getting reports, that while the pre-formatted reports showed the correct times, the reports generated by the custom report tool were reporting from a different time zone...not sure if that could be part of the problem...

Help!

mark

3 Replies
Mark Kizilos

I think I discovered the issue. It seems to be related to how I had set the course up to exit. The overall player default is set to always resume. I had set up a lightbox slide to prompt users to confirm whether to : save and quit (close lightbox then exit course trigger); Start over (close lightbox then Restart course trigger); or cancel and continue (close lightbox). When I uploaded to scormcloud i was able to see that strange things would happen (only on iPad running in mobile player)when I clicked "save and quit" or "start over."  i started to get the sense that the course didnt know whereto restart--perhaps it was going to the next trigger after the "exit" trigger and finding there was nowhere to go..?

So, my solution was to put the same options on a layer on the master slide. Now the course publishes on AO and is behaving as expected.

I hope that this solves this publishing issue for good, and that it wasn't just an unrelated coincidence that I unkowingly fixed something else while making these changes.

Anyway, the course now seems to be up and running on AO, but I now cant get it to work on sormcloud. I have been trying to decide which system to use, and I think that the easy access to the scormcloud api will make it a better choice ultimately-- i just need reporting (including from iPad users) and the ability to authenticate users from my application. In other words, Storyline+tincan hosted somewhere...I don't need most typical LMS features...

Mark

Mark Kizilos

Okay, I thought I had resolved this, but alas, no.

I id discover one thing that I think may be part of the problem:

1. Some jpeg images were not getting published with an accompanying swf file in the mobile folder when i tried publishing to LMS for scormcloud. I read in another post that all images should have both an image file and an Swf version. I figured this out because the only missing images were all jpegs, though not all jpegs were missing.  I have all my images on dropbox, but they are all synche dto the local machine I am publishing on. I converted these images to png files and they do now appear properly....

2. I discovered that I have a remnant of a previosly added and deleted results slide in the variables list. I see "Results2.Passed" in the list, but there is no associated Results2 slide---i had added a number of results slides and then deleted them. I cannot delete this variable, and I wonder if this might be causing some difficulties? I tried adding other results slides and i cant get any other results slide to create a variable with a similarly named variable---"ResultsX.Passed"

Could one pf these things be the issue? I guess I will be submitting a support ticket....I have been trying to fix this on my own because I have a client deadline looming.

Thanks for any ideas.

Mark