Articulate Presenter Files Stuck on Hard Drive

Hi - I am really flummoxed by this issue...

I created a Presenter piece on my hard drive that included audio, engage interactions and animation on the slides.

I was able to publish it and have it launched, but when I went to move the files over to our network drive, I was given a Presenter Error message referring to the fact that the PPTA file is read-only.  Looking at the directory on our network drive, there is not even a PPTA file there, only the PPTX. 

After trying many things, including using the Send Articulate Package option, I gave up and decided to recreate the project, just saving it directly to the network drive - I had created over 20 other modules directly on our network drive, so thought this might work.

Unfortunately, this does not work either - I can save the PPTX file, but when I go to the Articulate ribbon option, and attempt to add audio (or any other option), I get the following message:

Once again, looking at the directory, I don't see a PPTA file even existing at this point.

Any ideas?  This is getting to be a real issue - these files have to be accessible by others who are not on my laptop...

Thanks!

7 Replies
Brian Batt

Hi Brent,

If there's no PPTA file associated with that presentation yet & you click on the Articulate menu, Articulate will generate a PPTA file.  I think the message that you're seeing is related to the initial PPTA file creation.  Does clicking the Yes button create the PPTA file on your network?

Also, we do not recommend working off of a network drive.  Here are some tips for managing your files which can help prevent issues.

1.  Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 

2. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).

3.  Avoid using special characters, accents or symbols in your file names.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article:

http://msdn.microsoft.com/en-us/library/aa365247(VS.85).aspx

Brent Berheim

Thanks Brian - unfortunately, clicking on yes does not create the PPTA file either.

I appreciate your other suggestions, but unfortunately, we do need to save to our network files, as the base files for the presentation will need to be accesible to others who may need to work on this in the future.  I did try to do the Send to Articulate Package option that was suggested in a previous post, but that did not work either.

With regard to special characters, our naming convention uses the underscore ( _ ) character and no other special characters or accents, which I believe should be usable. Also - that naming convention has worked for many other pieces for this same overall project.

Path length is an interesting possibility - however, what I find odd is that files that I worked with and saved in a different directory that was just as deep seem to work just fine.

I thought that by creating a new base file I could make this work.  One thing I am wondering is if having the original (file from my C drive) open to style my new PPTX file is causing the issue??

Brian Batt

Hi Brent,

Are you sure that you have the proper read/write privileges on that network folder?

Also, can you tell me why using the "Send to" feature doesn't work?  When working on an Articulate Presenter presentation in a collaborative environment with other developers, I recommend that you use the following workflow: 

1. Use the Send to Articulate Presenter Package feature to make an exact copy of the project and the included Engage interactions and Quizmaker quizzes per the method in the article below: 

http://www.articulate.com/support/presenter09/?p=457

If the project files are already located on a network drive, proceed to Step 2.

If the project files are currently located on your local hard drive, skip to Step 6.

2. When you need to edit or publish the presentation, copy the ZIP file (the Articulate Presenter Package) from your network drive to your local hard drive.

3. Extract (unzip) the project files onto your local hard drive. 

4. Edit and / or publish the presentation as necessary.

5. Use the Send to Articulate Presenter Package feature (from Step 1) to make an exact copy of the updated project files.

6. Copy the resulting ZIP file to your network drive for storage and sharing.

7. Repeat Steps 2 through 6 whenever you need to edit or publish the presentation in the future.

By working on the main project files on your local hard drive, you prevent any corruption or erratic behavior of the files that might have occurred by working on a network drive (ie: random backups). Also, this method ensures that all of your Engage interactions and Quizmaker quizzes stay properly linked together.

Brent Berheim

Well - I seem to have read-write access to that drive for anything else.  I can save the PPTX file, open edit, etc.  Just the PPTX won't create.

When I tried the Send Articulate Package, it didn't capture the engage interactions that I needed, as I thought your description of the packager in an earlier post made it seem.

Again, what is most frustrating is that 20 other pieces worked just fine when saved on the network drive.

I am wondering if having the file that won't be moved open while working on the new file could be causing the problem.  I am going to try it with a different file.

Brian Batt

Are you using Windows XP?  Can you try the recommendations in the link below?

http://support.microsoft.com/kb/830903

Or try:

  1. In Windows Explorer, open the network folder that contains the file that you are trying to open or save.
  2. On the Tools menu, click Folder Options.
  3. Click Use Windows classic folders, and then click OK.
  4. Open the PowerPoint file

Let me know if that helps.

Brent Berheim

Good morning, Brian - Well, I think I figured out that the entire folder that I was saving the files to was corrupt.  I created a new folder at the same level, and now everything works fine.

I guess, after all, it might have been much ado about nothing...

Thanks for all the help and suggestions!