Articulate Presenter + Tin Can API + Error 400

Hi there

I've published Articulate Presenter 13 files as SCORM packages in the past and hosted them in my LMS (Moodle) with no issue. Completion data comes through fine.

I've started to explore Tin Can API as a potential replacement for SCORM, and am encountering some difficulties. I wonder if I could call on you fine people for assistance! I'm very much a novice when it comes to Tin Can so please bear with me.

My setup is as follows:

  • Articulate Presenter 13 presentation published with Tin Can;
  • Uploaded zipped file to the Tin Can Launch Link plugin on Moodle;
  • Learning Locker LRS set up to receive Tin Can statements;
  • Relevant LRS details (endpoint, key, secret, etc.) entered into the Tin Can Launch Link Moodle plugin.

When I go to play back the presentation my browser displays an error message, "Unable to connect to server. Please verify that you are connected to the internet. Retry?" And then it displays another message claiming a connection issue and referencing "Error 400" (see attached screenshot). This happens in Chrome, IE, Edge and Firefox.

My Learning Locker LRS records an instance of the presentation being launched, but that's it. Sometimes the presentation continues in the background but there's no further statements being captured by the LRS.

The only supporting documentation I can fine is here: https://articulate.com/support/article/unable-to-connect-to-server-when-launching-tin-can-api-content-at-scorm-cloud. I have found some references to this issue in older forum posts, but they seem to suggest it was fixed in subsequent updates. I'm using the latest version of Presenter 13.

What is this Error 400? And how can I overcome it?

Any help would be greatly appreciated!
Rob

1 Reply