Attachment (Links) opening on their own?

Does anyone have any idea why attachments that are set up as links are launching all by themselves when I launch an Articulate Presenter project in the browser? This is happening across both Mac and PC browsers.

Attachment link url's are as follows:  "/attachment_items/my_attachment.pdf"

("attachment_items" is a sub-directory in my Articulate Presenter published project folder that I created.)

6 Replies
Christine Hendrickson

Hi Jason,

I just want to make sure I understand what's going on. When you launch your presentation, the attachments are launching right off the bat, without any interaction, correct? What method are you using to attach the files?

You might want to take a look at this article, just to make sure you haven't missed any steps involved in adding the attachments. 

Jason Lampitt

Well, we're doing everything right.

I made a new project and created an Attachment as a link with the same relative URL. After publishing it to our development environment, I tested it and it works as expected.

Soooo... maybe we have a corrupt project?

Is there anything in the publish dialog (like an option) that would cause attachments to open on their own?

Christine Hendrickson

Hi Jason,

Thanks for getting back to me! That is very strange, indeed. I haven't heard of this happening, so I'm not quite sure what would cause this. I've done some extra digging, but I cannot find an option that would allow the attachments to launch automatically.

Could you please submit a support case with us? Please include a Presenter Package, so we can take a closer look at the files. I'd really like to see what's causing this, so if you can, please share your case number with me. 

Thanks again, Jason!