Audio erased and now runtime error

Nov 14, 2013

I really hope someone can help. I recorded audio for 55 slides yesterday. Saved it, everything was fine. Went to Publish it and got a runtime error. And when I went back to my presentation ALL my audio I recorded was GONE. The animations and annotations are all still there but no audio and I continue to get a run time error when trying to publish.

Runtime error '-2147319779(8002801d);:

Automation error

Library not registered


25 Replies
Leslie McKerchie

Hi Julee! Thanks for mentioning the troubleshooting that you have completed. As you can see here, I'm not sure that I have much more information to share regarding the previous reports.

I am curious if you are only having trouble with the one file or is it across files? 

You may want to try to import into a new file to see if that helps.

You may be able to resolve PowerPoint file corruption in this manner:

  1. Open a new, blank presentation in PowerPoint.
  2. Go to the Home tab, click the drop-down arrow beside New Slide, and choose Reuse Slides.
  3. In the Reuse Slides panel, click the Browse button and choose Browse File.
  4. Browse to your original PowerPoint file and click Open.
  5. At the bottom of the Reuse Slides panel, mark the box to Keep source formatting.
  6. Right-click the first slide in the Reuse Slides panel and select Insert All Slides.
  7. Save the new presentation and republish.

Note: Articulate resources, such as audio and video, will need to be inserted again into the new presentation. You may need to export the narration from your original presentation, then import it into the new presentation.

Julee Jaeger

I had a co-worker open the files and make changes to the file successfully so the file is okay. They are able to make changes to my file.

This is definitely a problem with my machine that is happening for every Power Point 2010 file that I open. I'm scanning for more info. For other runtime errors it appears there are .dll file changes or registry updates. Is there anything like that I can do?

Julee Jaeger

To clarify, I can open Slide Properties, Import Audio, Options, Preview, Player, and Publish, just not Add Annotations or Sync Animations.

There is one other snag. When I click "Edit Properties" on A Quiz/Survey module. Nothing happens. I click the Quizmaker Quiz button in Power Point/Articulate, and I can get to the properties, but none of my quiz/surveys show up as being apart of the file.  I can deal with this for the moment...will try to delete/re-add quizzes, but I need to be able to animate and annotate again.  Thanks!

Julee Jaeger

Can't add a quiz. =( this is a different problem, will search for another solution. Posting it here just in case these issues are related.

Symptoms: I click on the Quizmaker Quiz button, and it only lets me add Engage interactions. The same thing happens when I click the Engage Interaction button, but that is expected behavior.

Still searching for other troubleshooting info that I could provide on the runtime error when trying to annotate/animate.


Stephen McDermott

This has happened to me as well, minus the run time error.  I have a course in presenter with engage and quizmaker files embedded.  All the audio was in the file.  I made several text changes to the course and published it again as I have done many times.

On reviewing the uploaded course in the LMS, the audio files were not playing.  And the engage and quizmaker files did not play at all.  When I went back to my source files, every single narration was wiped.  All from publishing the course.  There is clearly a massive bug.  There was no error message, all worked as normal.  I would say the only thing I did differently was select publish for IOS mobile.

I have the course backed up, and when I checked it all was working.  However a mornings worth of updating my course is wasted, as I had to revert to an old scorm file.  However I will not be putting more work into my course, if the same problem will happen again.


Leslie McKerchie

Hi C! As you can see here, we did not get an update back from the user. If you have recently tried to repair your software as indicated above, I would recommend that you reach out directly to our support team here as I've seen the issue shared in this thread as well and we were unable to reach resolution with those users as well.

C Lupien

Success! I use Office 2010 and also installed trial version of  Office 15. I uninstalled Office 15 and that left a hangover registry key that needed to be deleted manually. Thanks to Victor at Support for speedy response!

"Make sure you have PowerPoint closed before making this change. We would also recommend backing up your registry or having your local IT group make this change."

"To further isolate this issue, may I confirm if you previously installed other versions of Microsoft Office? - We recently found similar issue which is caused by having a registry key leftover after uninstalling Office 2013. To fix the issue, you'll need to delete the following registry key:


By removing this key, Office properly falls back to the previous older version - 2.a - which is the correct installed version for PowerPoint 2010.

For reference, the entire incorrect key that is causing the problem is:


@="C:\\Program Files (x86)\\Microsoft Office\\Office15\\MSPPT.OLB"

This discussion is closed. You can start a new discussion or contact Articulate Support.