Can't fail a quiz if report is set to ".../incomplete"

Hello,

I have a problem with failing a quiz on my articulate presentations.  If the user passes the final quiz in a published presentation, Articulate runs fine.  By if they fail the final quiz in these tracking/reporting instances...

-Track by slides/report by complete/incomplete

-Track by percent/report by complete/incomplete

-Track by slides/report by pass/incomplete

-Track by percent/report by pass/incomplete

...then the presentation acts like the user has NOT complete the quiz by displaying a dialog box that reads "You must complete the quiz in order to continue" when the user tries to click the exit button, click on another slide, etc.  (I know there is a setting that doesn't let users click out of the quiz before they have finished it, which these presentations are obviously set to, but I don't know why the presentation acts like it's not complete).  Whether the user passes or fails they get to the slide after the quiz that tells them their score, it's only at this point that the dialog box comes up. 

You'll notice that the only times this happens is when the presentation is set to report by some form of "incomplete".  This happens no matter if it's published through SCORM 1.2, SCORM 2004, or AICC and no matter what browser it's being viewed in (Firefox 4 and the newest versions of Chrome and Internet Explorer were all tested).

I hope I explain myself clearly.  I have only been using Articulate for about a month so I'm pretty new to troubleshooting these issues.  Does this happen to anyone else? Is there a work-around?  (Besides changing that setting that lets a user click out of the quiz before completion).

Thank you!

1 Reply
Brian Batt

Hi S P and welcome to Heroes,

I apologize for the issues that you're having.  If you are experiencing issues with content in your LMS, please refer to the following Word of Mouth blog entry, which outlines common issues pertaining to viewing and tracking content in an LMS: 

http://www.articulate.com/blog/9-ways-to-troubleshoot-articulate-lms-issues/ 

If you continue to have problems in Studio '09, be sure to package the files properly for your LMS by using the method in the link below: 

http://www.articulate.com/blog/publish-to-lms-with-studio-09/

If you continue to have problems, please submit a support case to us so that we can take a closer look into the issues:

http://www.articulate.com/support/contact/