Course in Moodle showing up blank

Sep 22, 2011


When I am trying to run a course in Moodle, the course is showing up blank.

I published the course as a SCROM 1.2 and run Moodle 1.9 on a Shared hosting server. All requirements should be met (PHP, MySQL e.g.).

When I run the course outside Moodle on the server, there is no problem.

When I run the course in Moodle using IE, it shows a few syntax errors. One of them is:


I can't figger out what the problem is.

Any help is really appreciated.


4 Replies
Dan Marsden

usually a blank page in Moodle is a symptom of a PHP error - try turning debugging on and see if it displays any more info..

admin > server > debugging

turn "display errors" on and elevate the debugging level.

then try again and see if any more information about the error is displayed.

Please provide the "full" Moodle version number you are using - 1.9.X - eg 1.9.10, 1.9.3 etc - if you're using an older version of Moodle this could be the problem.

Also - please provide more info on when the blank page is shown - what are you doing when it occurs?

have a look through these:

if the blank page occurs when you are trying to upload the file to Moodle - see this:

Stijn van Hofwegen

Hello Dan,

Thank you for taking the time to take a look at my issue.

I'll try to be more specific:

What I see:

When I try to run the course, it doens't show a full blank window, but just the part where the scorm file should be show.


Moodle version

I'm currently running Moodle version 1.9.13+

However I have also tried 2.0.4+ and 2.1.1+, which resulted is the same issue.

I am runnen the same Moodle version (1.9.13+)  on a another cheap and small server(also shared hosting). No problems there.

SCORM file size

I started out with uploading a 30MB course, the TEST course I use now is apx. 1MB. 

The course is uploaded using FTP set to Binary.

I've put the moodledata folder on several locations, but it makes no difference.


When I run the debugging, it only shows information when I log in. Unfortunately it's a lot of info, which I have included as an attachment.


In result of the debugging I checked the phpMyAdmin and came across the following message:

"The additional features for working with linked tables have been deactivated."

Could this be part of the problem?

Thanks again.

Dan Marsden

sounds like it could be a slashargs issue - especially if it works on one server but not another. SCORM forces the use of something in Moodle called "slasharguments" - but some servers aren't configured to allow it by default - especially common for Godaddy hosting accounts and older servers running IIS 5/6

have a look here - hopefully it will help:

There are also a bunch of users who have posted about this in the moodle forums - a google search should turn up a bunch of useful posts.

Stijn van Hofwegen

I'm pretty sure I tried everything. But nothing seems to make a difference. So I gave up on solving the problem and rather focus on the source. Therefor I changed from webhosting to a virtual server. I guess only then you can be really sure it's all compatible.

Thanks for all the help though Dan, really appreciated it.

This discussion is closed. You can start a new discussion or contact Articulate Support.