Disable Autoplay

Hi, I am embedding versions of the generated SWFs for my learning objects into iframes on my website. At page load they are hidden and jquery moves them in and out of view.

I need these to not autoplay. What is happening is that all 5 start playing at once. Its quite the cacophony!

I have tried tweaking the embed tag in utils.js for each presentation with no luck. it currently looks like this (I am trying anything that has ever worked for flash or wmv, just not the right thing I guess.). Any assistance would be great, kind of stuck on launching this system right now.

Tx

John-

  strHtml += "<object play='false' classid='clsid:d27cdb6e-ae6d-11cf-96b8-444553540000' codebase='" + strLocProtocol + "//fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,79,0' width='" + nWidth + "' height='" + nHeight + "' align='" + strAlign + "' id='player'>";

strHtml += "<param name='scale' value='" + strScale + "' />";

strHtml += "<param name='movie' value='" + strSwfFile + "' />";

strHtml += "<param name='quality' value='" + strQuality + "' />";

strHtml += "<param name='bgcolor' value='" + strBgColor + "' />";

strHtml += "<param name='flashvars' value='" + strFlashVars + "' />";

strHtml += "<param name='autoplay' value='false' />";

strHtml += "<param name='autostart' value='false' />";

strHtml += "<param name='play' value='false' />";

strHtml += "<embed name='player' play='false' autoplay='false' autostart='false' src='" + strSwfFile +"' flashvars='" + strFlashVars + "' scale='" + strScale + "' quality='" + strQuality + "' bgcolor='" + strBgColor + "' width='" + nWidth + "' height='" + nHeight + "' align='" + strAlign + "' swLiveConnect='true' type='application/x-shockwave-flash' pluginspage='" + strLocProtocol + "//www.macromedia.com/go/getflashplayer' />";

strHtml += "</object>";

3 Replies
John Armstrong

Hmm, makes sense but it'll take me more then an hour

I am loading player.html via iframes so I may try instead to manage iframe contents via a simple link instead. Have it initially default to a screenshot with a play button and the click directs the iframe to player.html.

Poor Mans 'disable autoplay'