Engage Interaction not functioning properly

Here's a puzzle;  I recently transferred all our active Studio 13 course folders to Dropbox, having been running them on a laptop without difficulty for some while.   All the courses still run perfectly from the laptop, while downloading from and saving to Dropbox.

I then deleted Studio 09 from my desktop, and downloaded and activated Studio 13.  But when I run a course in the Dropbox folder, and try to Edit an interaction, there is no response at all.  If I try to insert the interaction into the course from the course folder, I get a box with "Critical Error; could not initialise Insert Engage Interaction dialogue."

If I run the interaction from the course folder, Engage opens with the interaction edit screen as normal, and the interaction runs perfectly using Preview.

The interaction runs perfectly in Articulate > Preview This Slide only in Presenter.

If I change the title of the interaction and file it separately in the course folder, I still cannot insert it and get the same error message.

Meanwhile if I use my laptop the course and all interactions function normally. So the problem lies in the desktop.  I have uninstalled Studio 13 and reinstalled it twice, with no change.  The machine runs on W7 Pro, and Powerpoint 2007; both have the latest updates. The system requirements include both of those.

All ideas welcomed!

 

 

 

7 Replies
Alyssa Gomez

Hi there Jon,

You'll always want to save and publish to your local hard drive (typically your C: drive). Working on a network drive can cause erratic behavior due to latency, such as file corruption, an inability to save changes, and loss of resources. 

If you save the files to the C: drive on your desktop computer, are you able to edit the interaction from there?

Jon Cousens

Hi Alyssa, I saved the Presenter file, which had been opened in Dropbox, to the C: drive; that didn't\work so I copied the whole course folder with all the interactions and presenter files to the C: drive and tried again.  The Presenter file opened fine, but none of the interactions respond to either Edit in Engage or Edit in Properties.

One of the interactions opened and ran in Preview this Slide, but the others open in Preview with the just the slide in Presenter with the interaction name etc.

The interactions all open in Engage from the folder, and run OK in Preview.

In short the behaviour is exactly as it was in Dropbox.

Using my laptop with S13 and the Dropbox folder, all is well.

regards

Alyssa Gomez

Thanks for that update, Jon, and I'm sorry that you haven't had any luck with your troubleshooting steps so far. At this point, I would recommend sending your Articulate Package to our Support Engineers to have a closer look. They'll test your file and work with you one on one to get this sorted out as quickly as possible!

Jon Cousens

Hi Leslie, sorry about delay, been having dreadful issues with Tin Can interfacing with our LMS, with complaints about quizzes locking up etc.  We don't think it's a Studio 13 problem, unless the Players are set up wrongly, but that might change!

 The problem about editing interactions I wrote about is not, IMHO, anything to do with any specific course file. The situation is that on my desktop (W7 Pro, Office 2007) I now have Studio 13 installed, but although all the course files open correctly, I cannot edit interactions or quizzes from the Powerpoint/Presenter screen.  Clicking on the boxes for Edit in Engage or Edit Properties has no response whatsoever. I can edit by opening the file for the Interaction or Quiz, and I can Preview them from the Powerpoint/Presenter screen.

The reason I'm sure this is a system problem is that it is exactly the same with all our course files, and that on another computer with Studio 13 all the courses open from Dropbox perfectly and function perfectly.

The difference between the 2 computers is that the desktop has W7 Pro/Office 2007 (both up to date) and the laptop has W10/Office 2013.  So although your website says that W7 and Office 2007 are OK for Studio 13 provided they are updated, it seems to me that this may not be the case.

I take your point about Dropbox, but it always works well with other computers, and using it is a perfect solution for working away from base, working with another S13 licensee 200 miles away who helps us with IT and content, and having a secure backup.  Working on courses in Dropbox is not the same as working on them on a memory stick.

What's your view on the OS/Office version question? 

 

Ashley Terwilliger

Hi Jon,

Thanks for the additional information - and I wanted to pop in here as Leslie is off for a couple days. I don't know what OS/Office set up she's using but my guess is some combination of Windows 8 or 10 - and Office 2013 (cause that's what I have) and I have heard of other users using Windows 7 and Office 2007. So I wouldn't want to rule that out entirely as not working 

You mentioned dropbox and although it can be a local install it still serves as a shared drive, and as such individual users could be moving files around, renaming them, etc. and that's when things start to go wonky. The fact that you're able to edit the file directly but not within the Presenter file could be the symptom of that movement as pulling it from within the Presenter file it's looking for the same file, path, etc. that it was initially inserted with. Since the other computer can access it - is that the one where it was initially started? That could explain it if it was initially created there and there may still be a copy of the Engage interaction in the initial Presenter file, as everything is linked and stored in the PPTA file, and when you link it the first time we also store the Engage file in the PPTA.