Please Decode Error Message!

Hey all,

I'm not sure if this is an articulate problem or a moodle problem. I've published a course and uploaded to Moodle. For some reason I have 2 random students who can't open it at all.I've checked and they both meet the minimum software requirements.

One of them sent me this error message which i was hoping someone might be able to decode cause I have no idea what it means.

800x600 Normal 0 false false false oNotPromoteQF /> EN-AU X-NONE X-NONE MicrosoftInternetExplorer4

0:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - Trying to create MSXML2.XMLHTTP in VBScript
1:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - intReCheckLoadedInterval=250
2:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - intReCheckAttemptsBeforeTimeout=240
3:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - IFrameLoaded
4:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - In GetAICCURL
5:Mon Oct 3 17:35:19 UTC+1100 2011 - GetQueryStringValue Element 'AICC_URL' Not Found, Returning: empty string
6:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - Querystring value =
7:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - GetAICCURL returning:
8:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - In DetectPreferredCommMethod, checking XMLHTTP
9:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - Checking IFrame
10:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - blnCanUseXMLHTTP=true
11:Mon Oct 3 17:35:19 UTC+1100 2011 - AICCComm - blnCanUseIFrame=true
12:Mon Oct 3 17:35:19 UTC+1100 2011 - ----------------------------------------
13:Mon Oct 3 17:35:19 UTC+1100 2011 - ----------------------------------------
14:Mon Oct 3 17:35:19 UTC+1100 2011 - In Start - Version: 3.3 Last Modified=09/29/2011 15:30:48
15:Mon Oct 3 17:35:19 UTC+1100 2011 - Browser Info (Microsoft Internet Explorer 4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; FunWebProducts; GTB7.1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322; AskTbNG2V5/5.9.1.14019))
16:Mon Oct 3 17:35:19 UTC+1100 2011 - URL: http://moodle.mhcc.org.au/pluginfile.php/1958/mod_scorm/content/2/index_lms.html
17:Mon Oct 3 17:35:19 UTC+1100 2011 - ----------------------------------------
18:Mon Oct 3 17:35:19 UTC+1100 2011 - ----------------------------------------
19:Mon Oct 3 17:35:19 UTC+1100 2011 - In ClearErrorInfo
20:Mon Oct 3 17:35:19 UTC+1100 2011 - GetQueryStringValue Element 'StandAlone' Not Found, Returning: empty string
21:Mon Oct 3 17:35:19 UTC+1100 2011 - GetQueryStringValue Element 'ShowDebug' Not Found, Returning: empty string
22:Mon Oct 3 17:35:19 UTC+1100 2011 - strStandAlone= strShowInteractiveDebug=
23:Mon Oct 3 17:35:19 UTC+1100 2011 - Standard From Configuration File - SCORM
24:Mon Oct 3 17:35:19 UTC+1100 2011 - Using Standard From Configuration File - SCORM
25:Mon Oct 3 17:35:19 UTC+1100 2011 - In LMSStandardAPI strStandard=SCORM
26:Mon Oct 3 17:35:19 UTC+1100 2011 - Calling Standard Initialize
27:Mon Oct 3 17:35:19 UTC+1100 2011 - In SCORM_Initialize
28:Mon Oct 3 17:35:19 UTC+1100 2011 - In SCORM_ClearErrorInfo
29:Mon Oct 3 17:35:19 UTC+1100 2011 - Grabbing API
30:Mon Oct 3 17:35:19 UTC+1100 2011 - In SCORM_GrabAPI
31:Mon Oct 3 17:35:19 UTC+1100 2011 - Searching with improved ADL algorithm
32:Mon Oct 3 17:35:19 UTC+1100 2011 - In SCORM_GetAPI
33:Mon Oct 3 17:35:19 UTC+1100 2011 - SCORM_GetAPI, searching opener
34:Mon Oct 3 17:35:19 UTC+1100 2011 - In SCORM_ScanParentsForApi, win=http://moodle.mhcc.org.au/mod/scorm/player.php?a=17&scoid=89¤torg=OHS_Act_ORG
35:Mon Oct 3 17:35:19 UTC+1100 2011 - SCORM_GrabAPI, returning
36:Mon Oct 3 17:35:19 UTC+1100 2011 - Unable to acquire SCORM API:
37:Mon Oct 3 17:35:19 UTC+1100 2011 - SCORM_objAPI=undefined
38:Mon Oct 3 17:35:19 UTC+1100 2011 - In InitializeExecuted, blnSuccess=false, strErrorMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.
39:Mon Oct 3 17:35:19 UTC+1100 2011 - ERROR - LMS Initialize Failed
40:Mon Oct 3 17:35:19 UTC+1100 2011 - In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

Help!

Kat

1 Reply
Peter Anderson

Hey Kat,

If you receive an "Unable to acquire LMS API" error when launching Articulate content in your LMS, this may be caused by the version of Java that you have installed.

Some LMS’s use a Java API object to load content. Since content created in Articulate does not require Java, please do the following:

*  Contact your LMS provider and ensure that your installed version of Java is compatible with the version of the LMS you are using.
*  Ensure that you have published your content properly as described in the following article:
http://www.articulate.com/blog/publish-to-lms-with-studio-09/

If this issue persists, make the following modification to your player template, and test your content again:

1)  Open your presentation in PowerPoint.

2)  Go to Articulate > Player Templates.
3)  Select the "Other" tab.
4)  Deselect (uncheck) "Launch presentation in new window".
5)  Close the Player Template manager, and save the change when prompted.
6)  Publish your presentation for LMS using the newly saved player template, and test the content in your LMS
Let me know if that resolves the issue for your students. Good luck!