Presenter with inserted Web Object displays "This program cannot..

Hi,

I tried inserting a Captivate 6 swf as a web object into a Presenter/powrepoint file and tried previewing it.  I get ...

I tried taking the web object out and I still get this message.  I've rebooted the computer and still get this message.

Other presentations work fine and the quizmaker slide in the suspect presentation will preview just fine as well. 

I read in the forum that the solution was to reinstall Articulate but really that's not a good solution since it takes several hours to get a help desk person to help.

I hate to think I have to rebuild the whole presentation.  I've never worked with Web Objects before and was really just playing around with Captivate 6 and Presenter to see how I can use them together. 

Thanks for any help.

11 Replies
Christine Hendrickson

Hi Karen,

I'm sorry to hear that you're having trouble with this. Have you tried publishing the file with the web object to test it? If you view a published Presenter '09 presentation on your local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail. To properly test your published content and share it with others, upload it to the environment for which it was published. Please review this article for more information.

If you haven't seen it already, this tutorial explains how to add Captivate movies to your Presenter presentation. You might want to just take a look to confirm you haven't missed any steps.

If the information above doesn't help resolve the issue, please let me know.

Thanks!

Christine Hendrickson

Hi Karen,

Sounds good! I'll check in with you in the morning to see if you were able to find any changes from your home computer. Also, if you do submit a support case, please share the case number with me. This way I can follow the progress of the case and share the resolution for any other community members that experience the same issue. 

Have a great evening! 

Karen Sugalski

Hi Christine,

I haven't had time yet this morning. I've been pulled in 18 directions (of course) and have a report I need to get done.  I want to do it when I wont be disturbed and can logically do it so i can document what I've done and the outcome.  thanks for checking though. I will keep you posted.

Thanks again,

You have a great day too!!

Karen Sugalski

Hi Christine, I did my test and had some interesting results.  i wrote up the entire "experiment" for you, Articulate support, and my boss (of course). Here it is:

On company computer-

File worked fine until I inserted a Web Object created in Captivate 6.  When I tried to preview the file with the embedded WO, I get a preview window that says "This program cannot display the webpage" as if the path is incorrect.

Even after I delete the Web Object, the original file cannot be previewed or published on my company computer.

Wanting a control and assuming company restrictions are causing the issue, I moved both the Presenter file and the published Captivate 6 file to my personal computer.

I was able to open and preview the original Presenter file with no problem.  I was also able to open and play the published Captivate 6 file with no problem. 

I then inserted the Captivate file into the Presenter file as a web object. 

At the inserted slide, I first get a script error (Line 312, char 3, Error Invalid Argument).  I selected yes to continue running the scripts.

The second error state that my browser didn’t support some of the content. It stated I needed to be running IE 9 which I am.  I also tried the preview in Chrome v23 which is way above the minimum requirement of Chrome v17 and got similar error messages.

On my personal computer, I was able to delete the web object and then open and run the Presenter file.  I was not able to do that on the company computer.

So that's it. If you have any suggestions it would be helpful.  The training project won't fail if we can't insert Captivate pieces but why have the tools if you can't play-errr- ,I mean work,  with them.

Anna Bradbury

Hi, I wondered if you were able to advise on the resolve that you came up with for this?

I have an error (not 100% sure if its the same) - I have inserted a number of Captivate 6 simulations into a course which I have published to SCORM. Now the captivates will not run (blank screen) - I wanted to check whether the SCORM publishing 'self contains' the captivates (web objects) or will it be attempting to retain the link (pathway) I have selected for the file.

If its trying to link to the existing pathway/document, is there a way to 'self contain' them - as the documents are stored on a local (not network) server? (is it data/downloads/filename.html)??

Any help would be great (sorry if I've linked this to the wrong conversation).

Anna

Christine Hendrickson

Good morning Anna,

I don't think publishing for SCORM would effect your web object. When you're inserting Captivate files, you'll need to take some additional steps to ensure they're inserted properly. If you haven't already, you might want to take a look at this article (which also contains a helpful video on the process from Brian). If you're viewing the content locally after publishing, make sure you pay special attention to the instructions on this topic.

Have a look and let me know if you're still unable to view your content.

Thanks!