Problem with viewing an inserted YouTube video in IE9

I have a course that has a YouTube video inserted as a web object. I can view in FireFox just fine.

1. When I view it in Internet Explorer 9 (IE9), a security message pops up and says, "Only secure content is displayed".

2. I click the only option, "Show all content".

3, Then another message appears that says the web browser needs to resend the information.

4. So when I click "Retry", it appears as if the course reloads, and I am asked if I want to resume where I left off.

5. When I select "Yes", I resume back to the slide and the video will play.

I am also viewing the course in my LMS, and it is published to SCORM 2004, 3rd edition, in case that matters.

I am sure it is because of security setting in IE9, but which one? Does someone know what security settings I need to change?

Thanks for your help. I am attaching screenshots of what I see.

6 Replies
Peter Anderson

Hey Lesley!

Would you like to send us your files so we can try to replicate what you're experiencing? Please create an Articulate Presenter package, then upload the zip file to our server. You can review how to do this here: 

 

Send to Articulate Presenter Package – Articulate Presenter ’09 Help

 

Upload the resulting zip file from your computer to our server using this upload form: 

 

Articulate Support - Upload Your Files for Review 

 

Please be sure to include a description of your issue, your version of PowerPoint, version of Windows and version of Presenter '09, which you can find in Help and Support -> About Articulate Presenter. Please also include the URL for this thread so I can follow up with you personally in the forums. And feel free to come back and leave your case number here so I can keep a close eye on it. Thanks!

Peter Anderson

Hey Lesley!

Just curious to know if the below solution Jonathan sent you has resolved this for you:

"The steps here basically clears the cache of Internet Explorer and resets the settings. Updating the Flash Player just makes sure that you have the latest version in your sytem: 


1) Upgrade Adobe Flash Player here: 
http://www.adobe.com/go/getflash 

2) Clear your browser cache. You can do this in Internet Explorer by going to Tools > Internet Options > General > Temporary Internet Files. Select Delete Cookies and Delete Files. 

3) Also in Internet Options, on the Security, Privacy, and Advanced tabs, reset everything to its default settings. There is a button on each tab to reset defaults. 

4) In Windows Vista / 7, go to Start > All Programs > Accessories > Run. In Windows XP, go to Start > Run. 

5) Copy / paste the following line of text (depending on your operating system) into the Run dialog box. Click OK, and delete the entire contents of the window (folder) that opens. 

Windows Vista / 7: 
"C:\Users\%username%\AppData\Roaming\Macromedia\Flash Player\#SharedObjects" 

Windows XP: 
"C:\Documents and Settings\%username%\Application Data\Macromedia\Flash Player\#SharedObjects" 

6) Close all browser windows for the changes to take effect, and then test your content again. 

If it's still giving you the warning message, try to search the Microsoft website for steps on how to automatically load non-secure items in Internet Explorer 9. I believe it's in their knowledge-base website."

Lesley Mizer

Hello, Peter!

Thanks so much for following up with me, and many thanks for Jonathan for taking the time to suggest the instructions above! I still received the security message, however, I don't think I followed the instructions correctly. It wasn't obvious to me where to reset the settings in the Privacy and Advanced tabs that are mentioned in step 3. The message on the Advance tab made me afraid to Reset! Is that the right Reset button?

I did open Run and followed the rest of the instructions, and there were not any contents in the folder as mentioned in Step 5.

I did find steps for loading non-secure items at http://support.microsoft.com/kb/2625928, but they try to scare you into not doing it, so I haven't. Do you think it would be fine to do that?

Thanks again for all of your help!

Peter Anderson

Hi again Lesley!

I just had a chance to test the content myself and I'm not having any trouble viewing the Web object in IE9 either. So there's definitely a setting on your end preventing it from playing. Did you update to the latest version of Flash? That would be the easiest place to start. As far as the Microsoft Secure Content setting, my own IE9 browser is set to Prompt, and like I said, I didn't experience any trouble, so I'm not sure that's your last resort if you're uncomfortable with it. With that said, if you've tried everything and still can't get it to play correctly, I'd let Jonathan know and he can continue to work with you to get it resolved. 

Sorry for the frustration, but I'm confident we'll get that Web object functioning properly for you. I'll continue to keep my eye it as well.