Publishing and LMS Issues

Hello,

I am working with our LMS administrator and they are having issues when starting the index_lms.html file.

I initally published the course SCORM 1.2 and the LMS administrator received the following error message when starting the course:

0:Tue Jun 26 11:05:11 UTC+0200 2012 - AICCComm - Trying to create MSXML2.XMLHTTP in VBScript
1:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - intReCheckLoadedInterval=250
2:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - intReCheckAttemptsBeforeTimeout=240
3:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - IFrameLoaded
4:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - In GetAICCURL
5:Tue Jun 26 11:05:12 UTC+0200 2012 - GetQueryStringValue Element 'AICC_URL' Not Found, Returning: empty string
6:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - Querystring value =
7:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - GetAICCURL returning:
8:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - In DetectPreferredCommMethod, checking XMLHTTP
9:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - Checking IFrame
10:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - blnCanUseXMLHTTP=true
11:Tue Jun 26 11:05:12 UTC+0200 2012 - AICCComm - blnCanUseIFrame=true
12:Tue Jun 26 11:05:12 UTC+0200 2012 - ----------------------------------------
13:Tue Jun 26 11:05:12 UTC+0200 2012 - ----------------------------------------
14:Tue Jun 26 11:05:12 UTC+0200 2012 - In Start - Version: 3.3 Last Modified=06/24/2012 11:59:08
15:Tue Jun 26 11:05:12 UTC+0200 2012 - Browser Info (Microsoft Internet Explorer 4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; GTB7.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E; InfoPath.1; MS-RTC LM 8))
16:Tue Jun 26 11:05:12 UTC+0200 2012 - URL:
file:///L:/Siemens%20Learning%20Manager/WBTs/SALES/AACC/v1/Chapter0/index_lms.html
17:Tue Jun 26 11:05:12 UTC+0200 2012 - ----------------------------------------
18:Tue Jun 26 11:05:12 UTC+0200 2012 - ----------------------------------------
19:Tue Jun 26 11:05:12 UTC+0200 2012 - In ClearErrorInfo
20:Tue Jun 26 11:05:12 UTC+0200 2012 - GetQueryStringValue Element 'StandAlone' Not Found, Returning: empty string
21:Tue Jun 26 11:05:12 UTC+0200 2012 - GetQueryStringValue Element 'ShowDebug' Not Found, Returning: empty string
22:Tue Jun 26 11:05:12 UTC+0200 2012 - strStandAlone= strShowInteractiveDebug=
23:Tue Jun 26 11:05:12 UTC+0200 2012 - Standard From Configuration File - SCORM
24:Tue Jun 26 11:05:12 UTC+0200 2012 - Using Standard From Configuration File - SCORM
25:Tue Jun 26 11:05:12 UTC+0200 2012 - In LMSStandardAPI strStandard=SCORM
26:Tue Jun 26 11:05:12 UTC+0200 2012 - Calling Standard Initialize
27:Tue Jun 26 11:05:12 UTC+0200 2012 - In SCORM_Initialize
28:Tue Jun 26 11:05:12 UTC+0200 2012 - In SCORM_ClearErrorInfo
29:Tue Jun 26 11:05:12 UTC+0200 2012 - Grabbing API
30:Tue Jun 26 11:05:12 UTC+0200 2012 - In SCORM_GrabAPI
31:Tue Jun 26 11:05:12 UTC+0200 2012 - Searching with improved ADL algorithm
32:Tue Jun 26 11:05:12 UTC+0200 2012 - In SCORM_GetAPI
33:Tue Jun 26 11:05:12 UTC+0200 2012 - SCORM_GrabAPI, returning
34:Tue Jun 26 11:05:12 UTC+0200 2012 - Unable to acquire SCORM API:
35:Tue Jun 26 11:05:12 UTC+0200 2012 - SCORM_objAPI=object
36:Tue Jun 26 11:05:12 UTC+0200 2012 - In InitializeExecuted, blnSuccess=false, strErrorMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.
37:Tue Jun 26 11:05:12 UTC+0200 2012 - ERROR - LMS Initialize Failed
38:Tue Jun 26 11:05:12 UTC+0200 2012 - In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

From the setting SCORM 1.2, this is the message from the LMS administrator, "

I've just talked to Patrick. The WBT is working and the scorm file is fine, but the problem what we have is, that the transfer of status quo of the WBT doesn't work.  There is no message if the user already started or passed the WBT. That means you can do the WBT, but you cannot pass it and therefore you will not get a certificate. Patrick will clarify this issue with his IT colleagues and we will come back as soon as possible."

 

They're saying that the course works fine; however, the course is not tracking 'course completion.

Then I published the course AICCThe following is the message from the LMS administrator: (it looks like the same error message when starting the course):

"The version with AICC doesn't save the progress at all.

But the index_lms.html - file in this version works without any problems.

 

may in the SCORM - version you just have to fix the error when starting that file.

When I start the the index_lms.html here there, this error occurs:"

 

0:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - Trying to create MSXML2.XMLHTTP in VBScript
1:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - intReCheckLoadedInterval=250
2:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - intReCheckAttemptsBeforeTimeout=240
3:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - IFrameLoaded
4:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - In GetAICCURL
5:Wed Jun 27 16:43:31 UTC+0200 2012 - GetQueryStringValue Element 'AICC_URL' Not Found, Returning: empty string
6:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - Querystring value =
7:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - GetAICCURL returning:
8:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - In DetectPreferredCommMethod, checking XMLHTTP
9:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - Checking IFrame
10:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - blnCanUseXMLHTTP=true
11:Wed Jun 27 16:43:31 UTC+0200 2012 - AICCComm - blnCanUseIFrame=true
12:Wed Jun 27 16:43:31 UTC+0200 2012 - ----------------------------------------
13:Wed Jun 27 16:43:31 UTC+0200 2012 - ----------------------------------------
14:Wed Jun 27 16:43:31 UTC+0200 2012 - In Start - Version: 3.3 Last Modified=06/24/2012 11:59:08
15:Wed Jun 27 16:43:31 UTC+0200 2012 - Browser Info (Microsoft Internet Explorer 4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; GTB7.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.1; .NET4.0C; .NET4.0E; MS-RTC LM 8))
16:Wed Jun 27 16:43:31 UTC+0200 2012 - URL:
file:///L:/Siemens%20Learning%20Manager/WBTs/SALES/AACC/v1/Chapter0/index_lms.html
17:Wed Jun 27 16:43:31 UTC+0200 2012 - ----------------------------------------
18:Wed Jun 27 16:43:31 UTC+0200 2012 - ----------------------------------------
19:Wed Jun 27 16:43:31 UTC+0200 2012 - In ClearErrorInfo
20:Wed Jun 27 16:43:31 UTC+0200 2012 - GetQueryStringValue Element 'StandAlone' Not Found, Returning: empty string
21:Wed Jun 27 16:43:31 UTC+0200 2012 - GetQueryStringValue Element 'ShowDebug' Not Found, Returning: empty string
22:Wed Jun 27 16:43:31 UTC+0200 2012 - strStandAlone= strShowInteractiveDebug=
23:Wed Jun 27 16:43:31 UTC+0200 2012 - Standard From Configuration File - SCORM
24:Wed Jun 27 16:43:31 UTC+0200 2012 - Using Standard From Configuration File - SCORM
25:Wed Jun 27 16:43:31 UTC+0200 2012 - In LMSStandardAPI strStandard=SCORM
26:Wed Jun 27 16:43:31 UTC+0200 2012 - Calling Standard Initialize
27:Wed Jun 27 16:43:31 UTC+0200 2012 - In SCORM_Initialize
28:Wed Jun 27 16:43:31 UTC+0200 2012 - In SCORM_ClearErrorInfo
29:Wed Jun 27 16:43:31 UTC+0200 2012 - Grabbing API
30:Wed Jun 27 16:43:31 UTC+0200 2012 - In SCORM_GrabAPI
31:Wed Jun 27 16:43:31 UTC+0200 2012 - Searching with improved ADL algorithm
32:Wed Jun 27 16:43:31 UTC+0200 2012 - In SCORM_GetAPI
33:Wed Jun 27 16:43:31 UTC+0200 2012 - SCORM_GrabAPI, returning
34:Wed Jun 27 16:43:31 UTC+0200 2012 - Unable to acquire SCORM API:
35:Wed Jun 27 16:43:31 UTC+0200 2012 - SCORM_objAPI=object
36:Wed Jun 27 16:43:31 UTC+0200 2012 - In InitializeExecuted, blnSuccess=false, strErrorMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.
37:Wed Jun 27 16:43:31 UTC+0200 2012 - ERROR - LMS Initialize Failed
38:Wed Jun 27 16:43:31 UTC+0200 2012 - In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

So, I reviewed the Articulate 'Word of Mouth' Blog for some possible answers. The following is the closest instructions I found to attempt to fix the problem.

 I asked the LMS administrator to send me what the URL looks when pointing the course to the "index_lms.html file." (I also sent instructions to try the below action):

Studio ’09: Learn how to generate a debug log in Studio ’09 here.

You can generate a debug log if you’re using AICC by doing the following:

  1. Add ShowDebug=true to your launch URL.
  2. Your launch URL should look something like this:
    http://host/PRESENTATION_DIR/index_lms.html?ShowDebug=true&AICC_SID=123&
    AICC_URL=http://host/lms/lms/aicc.asp

 Can anyone provide some other ideas as to how to fix this problem?

3 Replies
Vivian Deitz

Good morning Joe,

thank you for your response. The LMS administrator still cannot get this to work. Below is his latest reply:  is it possible to set up a meeting so you and he can discuss this issue.  He is in Germany and it is 2:30 there now. So if we can set something up in the next hour - that would be great.

Here is his reply:

when I linkt the imsmanifest.xml - file instead of the player.html, The (when I'm starting the WBT) I only see the content of the XML file:

I can't see to attach the error message, the copy and paste will not work.

The LMS System is TC Manager and our company's LMS Siemens Learning Manager.

Can you please try to meet with this administrator to try and figure this out?

thank you Joe.

Lazaro Perez

Hi Vivian,

We have been encountering the same issues for two weeks on our side.

At least on our side we managed to narrow it down to an issue with the new JAVA version.  When we roll back to Java Version 6 Update 31 all the issues go away... Just something to try.

We are wroking with SCORM 1.2 files on a Docent 6.5 LMS.