Publishing error - quiz won't open

Quiz is not NOT appearing in published course.

I have 4 related courses that have all previously been successfully published. When I revised, re-published, and tested the courses yesterday, the Assessment did not load for 2 out of 4 of the courses. Instead, when I went to the Assessment page, it was just a black screen with the "loading circle" animation going around and around and around...  If I tried to click the outline, I did get the standard Quizmaker warning that I had to finish the quiz before going to another slide.

What the heck is going on?! 

At first, I thought the problem might be that the other work I'd been doing on the PC while the course was publishing had interfered with that process. But I re-published one of the courses this morning (and didn't do anything on the PC while publishing), and I got the same error. I checked the Quiz in QuizMaker, and it Previewed just fine. I tried re-inserting into the course, but still got the same error! FYI: I always work on my local hard drive, not the network, so that is not the issue. It's beginning to feel like Articulate has special programming that recognizes when I'm under deadline -- and them messes up in some inexplicable way.

Any ideas, Articulate?

3 Replies
Christine Hendrickson

Hi Judy,

I apologize for all the trouble you're having with your quizzes. Hopefully we'll be able to resolve this quickly. 

You mentioned an error you received a couple of times in your post, but I'm not quite clear on what error is showing. Is it something like this

I completely understand that you're under a deadline and would like to get this problem fixed quickly. Would you mind submitting a support case with our technical department? They'll be able to take a closer look at your files and see what may be causing the issue. Please be sure to include a Presenter Package, as well, this will make the process faster for you. 

If you do open a support case, please share the case number with me. You can do this by responding to this message, or by sending it to me in a private message. I'll monitor the progress of your case.

Again, I apologize for the trouble, hopefully we'll have you up and running soon.

Judy Nollet

Christine,

Thanks for the quick reply. The error you linked to is NOT the error I'm getting. What I get is that it looks like the Quiz is loading, but it never does. The big-circle icon just keeps spinning and spinning.

I have submitted the issue to Articulate; the support case # is 00305306. I uploaded both the package with the source files and the published version of the course.

FYI: I re-created the quiz from scratch, inserted that, and re-published. That fixed the problem -- for now. But it doesn't explain WHY quiz files worked for a while and then suddenly went bad. This is what I find so frustrating; the software just isn't trustworthy.

Christine Hendrickson

Hi Judy,

Thanks for getting back to me, I appreciate the additional information. I'm also happy to hear that you were able to re-create the quiz and get it working.

Again, I apologize for the trouble and frustration. Unfortunately, it sounds like the files were corrupted. There's no real way to pinpoint what may have caused this, but hopefully you won't run into this issue again.

To avoid issues like this in the future, there are a few best practices to keep in mind:

1.  Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 

2. You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).

3.  Avoid using special characters, accents or symbols in your file names.

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article:
http://msdn.microsoft.com/en-us/library/aa365247(VS.85).aspx