Score not being recorded

When doing a quiz  the score is not being recorded. When you view the results the score is 0.

We are using Moodle 2.1 

Any help would be appreciated.

Log:

0:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - Trying to create MSXML2.XMLHTTP in VBScript
1:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - intReCheckLoadedInterval=250
2:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - intReCheckAttemptsBeforeTimeout=240
3:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - IFrameLoaded
4:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - In GetAICCURL
5:Tue Dec 17 13:33:44 UTC+0100 2013 - GetQueryStringValue Element 'AICC_URL' Not Found, Returning: empty string
6:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - Querystring value =
7:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - GetAICCURL returning:
8:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - In DetectPreferredCommMethod, checking XMLHTTP
9:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - Checking IFrame
10:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - blnCanUseXMLHTTP=true
11:Tue Dec 17 13:33:44 UTC+0100 2013 - AICCComm - blnCanUseIFrame=true
12:Tue Dec 17 13:33:44 UTC+0100 2013 - ----------------------------------------
13:Tue Dec 17 13:33:44 UTC+0100 2013 - ----------------------------------------
14:Tue Dec 17 13:33:44 UTC+0100 2013 - In Start - Version: 3.3 Last Modified=12/17/2013 13:12:00
15:Tue Dec 17 13:33:44 UTC+0100 2013 - Browser Info (Microsoft Internet Explorer 4.0 (compatible; MSIE 7.0; Windows NT 6.2; WOW64; Trident/6.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; InfoPath.3))
16:Tue Dec 17 13:33:44 UTC+0100 2013 - URL: http://elearning.bdo.nl/pluginfile.php/4509/mod_scorm/content/9/index_lms.html
17:Tue Dec 17 13:33:44 UTC+0100 2013 - ----------------------------------------
18:Tue Dec 17 13:33:44 UTC+0100 2013 - ----------------------------------------
19:Tue Dec 17 13:33:44 UTC+0100 2013 - In ClearErrorInfo
20:Tue Dec 17 13:33:44 UTC+0100 2013 - GetQueryStringValue Element 'StandAlone' Not Found, Returning: empty string
21:Tue Dec 17 13:33:44 UTC+0100 2013 - GetQueryStringValue Element 'ShowDebug' Not Found, Returning: empty string
22:Tue Dec 17 13:33:44 UTC+0100 2013 - strStandAlone= strShowInteractiveDebug=
23:Tue Dec 17 13:33:44 UTC+0100 2013 - Standard From Configuration File - SCORM
24:Tue Dec 17 13:33:44 UTC+0100 2013 - Using Standard From Configuration File - SCORM
25:Tue Dec 17 13:33:44 UTC+0100 2013 - In LMSStandardAPI strStandard=SCORM
26:Tue Dec 17 13:33:44 UTC+0100 2013 - Calling Standard Initialize
27:Tue Dec 17 13:33:44 UTC+0100 2013 - In SCORM_Initialize
28:Tue Dec 17 13:33:44 UTC+0100 2013 - In SCORM_ClearErrorInfo
29:Tue Dec 17 13:33:44 UTC+0100 2013 - Grabbing API
30:Tue Dec 17 13:33:44 UTC+0100 2013 - In SCORM_GrabAPI
31:Tue Dec 17 13:33:44 UTC+0100 2013 - Searching with improved ADL algorithm
32:Tue Dec 17 13:33:44 UTC+0100 2013 - In SCORM_GetAPI
33:Tue Dec 17 13:33:44 UTC+0100 2013 - SCORM_GrabAPI, returning
34:Tue Dec 17 13:33:44 UTC+0100 2013 - Unable to acquire SCORM API:
35:Tue Dec 17 13:33:44 UTC+0100 2013 - SCORM_objAPI=object
36:Tue Dec 17 13:33:44 UTC+0100 2013 - In InitializeExecuted, blnSuccess=false, strErrorMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.
37:Tue Dec 17 13:33:44 UTC+0100 2013 - ERROR - LMS Initialize Failed
38:Tue Dec 17 13:33:44 UTC+0100 2013 - In DisplayError, strMessage=Error - unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support.

4 Replies
Dan Marsden

as Phil mentions - Moodle 2.1 is not supported anymore - there are a number of SCORM related bugs especially with more modern browsers that are fixed in newer versions of Moodle - you should be upgrading your Moodle site at least every 18 months to the latest major release. (Moodle releases a new major release every 6 months so ideally you should never be more than 2 versions behind the latest release.