Sound in Flash file is not paused in articulate presenter.

Hi,

I have created the flash file in main timline with animation and sound, and imported the same flash file to the Articulate Presenter.

While playing the SWF file in Articulater Presenter, it paused the animation only but not the sound after clicking the pause button. Sound in the flash file is indenpently playing in articulate presenter after pressing the pause button.

Could any one please help on this problem.

Thanks and Regards

Irfan

6 Replies
Paul Kornman

Welcome to Heroes.

I'm guessing that your sound is playing as part of a script. If the sound is in its own layer in your flash file (so you can actually see a wiggly line in the layer view representing the audio), the pause button should pause the sound.

If the sound is playing in reaction to a script, you'd need to add additional scripting to constantly monitor the status of the Play/Pause button in Articulate to determine if the Slide is "playing" or not and act accordingly.

Another solution would be to remove the sound file from flash and import it into Articulate.

(By the way, you'd have a similar problem if you had an animation or interaction moving as a result of a script).

Think of the "play/pause" button as moving (or stopping) the Flash playhead from frame to frame and nothing else.

Mohammed Irfan

Paul,

I haven’t used any script in the flash file, it is fully motion animation with sound file in one separate layer. whether i have to change any settings in flash file or articulate file. In articulate file, i have imported the flash file by using the sync with movie clip. Could you please give me any other solution for this concern.

Thanks and Regards,

Irfan

Peter Anderson

Hi Mohammed,

Would you like to send us your project files so we can take a closer look? If so, please create an Articulate Presenter package, then upload the zip file to our server. You can review how to do this here: 

 

Send to Articulate Presenter Package – Articulate Presenter ’09 Help

 

Upload the resulting zip file from your computer to our server using this upload form: 

 

Articulate Support - Upload Your Files for Review 

 

Please be sure to include a description of your issue, your version of PowerPoint, version of Windows and version of Presenter '09, which you can find in Help and Support -> About Articulate Presenter. Please also include the URL for this thread so I can follow up with you personally in the forums. And feel free to come back and leave your case number here so I can keep a close eye on it. Thanks!

Paul Kornman

I had a further thought...

In Flash, If you "Rewind", then 'Play", then "Stop/Pause" before the end, does the sound continue to play?

If so, you may need to adjust the sound properties in Flash.

Try this: (I'm using Flash Professional 5.5 - older versions may have this in a different location)

1) Select the frame that the sound File is in

2) In the Properties Panel, look at Sound Properties: the "Sync" value should be set to "Stream" not "Event" or "Start" or "Stop"

3) If it's not "Stream", change it to 'Stream" and try "rewind"ing, "play"ing and "stop"ing. If the sound stops (Hooray), re-publish the SWF and try it again in Articulate

-- or --

Remove the Sound file from Flash and import it into Articulate.

Good luck,

Paul