Videos NOT playing on the iPad using Articulate Mobile Player

Hi,

I created a presentation that includes several slides with videos. Several of the source videos are wmv and one is mp4. The presentation was published for normal Flash output and for the Mobile Player. The presentation has been uploaded to a server and a link created to run it from a webpage. 

The presentation runs fine and videos play when it’s viewed on a PC or Mac, in the Flash version.  When I access the webpage on an iPad and click on the presentation, I’m prompted to download the Mobile Player from the App Store.  Once I launch the presentation it plays the fine until I come to a slide with a video. The video is set to start about 30 seconds into the slide after some VO finishes. The video doesn’t play.

I enabled offline viewing when publishing, so if I download the presentation to iPad the videos play without issues. 

I also accessed the webpage using an Android tablet, installed the Mobile Player and the videos played correctly without downloading to the tablet.

Finally, I uploaded the presentation to another server and when I access it from the iPad using the Mobile Player, the videos play correctly.

I’m trying to go through a process of elimination to resolve this but I’m now stuck.  Is there any reason why the videos would not play on an iPad (but OK on an Android) when the presentation is accessed from a particular server and viewed on the Mobile Player? I’ve tried three different iPads.

Thanks for your help!

John

 

3 Replies
Ashley Terwilliger-Pollard

Hi John,

I'm happy to hear you were able to get the videos working eventually, but it may be that particular server doesn't allow for videos to play offline or within iOS, or even within the App in iOS? There are some reasons the videos may not play as described here that may get you started on ideas, but if it worked in one server, are you able to reach out to your hosting team and see if they had any other ideas? 

John  McFadden

Hi Ashley,

Thanks for your response.  Unfortunately, my problem isn't actually solved because the server the presentation works on is a private one, not the one it needs to be hosted on. I'll forward the link you gave me to our web services team to see if it helps. It's just weird that it works with the Android player and not iOS.

I'd still welcome any suggestions from other who may have experienced this problem.

Thanks,

John