Web object compatibility problem with Internet Explorer

Hello,

If I embed certain URLs via the web object, they end up faulty in Internet Explorer.

I have prepared an example for you:

http://www.gotitvideos.com/test_web_object/player.html

1) In FireFox and Chrome, the page displays correctly and I see the cursor and can select text.

2) In Internet Explorer, the page displays in the slide but I cannot see the cursor - and when I select text and click inside the selection, it somehow "replicates".

What is the reason for this faulty behavior and how can it be fixed? How could I test for other probable error causes apart from Articulate Presenter?

Thanks

Ben

P.S.:

The embedded page (http://codemirror.net/mode/clike/index.html) works without any problems in Internet Explorer if I open it on its own.

(In Opera, the URL is opened in a new window, even though it is set to display in the slide and this works in the other browsers... why?)

9 Replies
Ben B

Hi Geert,

thank you for your reply

I also run IE9 64bit, latest version, all patched, default settings.

The finding regarding IE9 has also been verified by a friend of mine :(

If you click inside the code, can you see the text cursor?

If you select text inside the code and then click the selection, does it replicate?

Cheers,

Ben

Ben B

Can anyone else confirm the problem with Internet Explorer 9 on the code slide in the following presentation (clicking into code does not show cursor)?

http://www.gotitvideos.com/test_web_object/player.html

Could it be related to some IE9-specific JavaScript or CSS-tweaks of articulate presenter or rather an IE-Issue?

Thank you,

kind regards

Ben

Timothy August

I just wanted to send in my solution, as I've had one of my program's users contact me with this issue, and I just spent hours trying to figure it out.

At least for me, it seemed to be specific to IE 9.  If I viewed the module in IE 7/8, it did fine.  There seemed to be 2 issues at play.  The first and most important step was simply selecting to view the module in "Compatibility Mode" (under "Tools" in IE 9).

Secondly, my website is SSL, and the YouTube "web object" in the module is not, so even with the above, a pop-up would warn of mixed content.  If that's the case for anyone else, you can (or advise your users to) go to Tools>Internet Options>Security>Custom Level.  Scroll down, and under "Miscellaneous", choose to enable "Display Mixed Content".  This will prevent the playback from stalling while awaiting your answer to the "mixed content" pop-up.

Personally, I'm about to a point where I'm ready to tell all of my program's participants to just use Chrome or Firefox.  I strongly recommend it in the "System Requirements", but of course many are still stuck on Explorer.  I have yet to have any real issues with anything but Explorer.  

Anyway, hope that helps.

Tim