Web Object not working when viewed in Saba (Presenter '09)

I do not have this problem in Storyline - just Presenter '09. I've never used a Web Object in Presenter, so this never came up.

I have an HTML page uploaded to our Saba content server. That HTML page has a video embedded in it. When I view the published course locally or on any non-Saba server, the page loads fine.

But when I upload the SCORM course to Saba and it gets to the Web Object page, it just says "Loading..." on the top-right portion of the white page.

Anyone else experienced this? I also wonder if this also occurs in Presenter '13 (we are about to upgrade).

5 Replies
Christine Hendrickson

Hi Chris,

Have you tried viewing this in a different web browser? If so, does the same thing happen? If not - which web browsers work/don't work?

You mentioned you tested this on a non-Saba server - which server did you try? Was it SCORM Cloud or another server?

If you'd like, you're welcome to share the project package with me. I can upgrade it to Studio '13 and send you the published files for uploading - just keep in mind that you won't be able to modify those files with Studio '09. I'm not sure if that will help at all, but I'd be happy to try if that's something you think may help.

If you'd like me to publish with '13, please create an Articulate Presenter package by following the steps in the following article:

Send to Articulate Presenter Package

If the file's not too large, and you're comfortable sharing it here, you can attach it to this thread. If it's too large, you can send it in as a support case - just be sure to ask for my attention and share the case number with me. 

Thanks!

Chris Perez

Thanks for the reply, Christine.

I thought I had tested the issue in multiple browsers, but apparently I only tested some alternate workarounds in different browsers. :\

When I say I tested it on other servers, I mean non-SCORM servers - just running the content like a web page. It works correctly in all browsers. The issue I had with Saba was in Firefox. I just used IE in Saba and opened the course and the page loads.

So this appears to be an issue with Firefox (and I was also able to reproduce the issue in Chrome). So the Web Object will not load in Firefox or Chrome when the course is viewed in Saba, but it does work in IE.

(I was also able to verify i have the latest Flash player installed).

Christine Hendrickson

Hi Chris,

Great information - thank you for the update. 

So, you've tested on a web server and haven't seen any issues. Can you try uploading to SCORM Cloud using the link I provided earlier and let me know if the same thing happens? It probably will - but it would help to find out whether or not it's an issue with the SCORM content, or the LMS, etc.

Here's more info that may help with testing this:

You can test your course here: SCORM Cloud  

If you're using AICC content please take a look at the article below for testing information:

Articulate Support - Testing AICC content at SCORM Cloud

 

Honestly a little strange that it's working in IE, but not Chrome or Firefox.

If you'd like to share the link, I'd be happy to do a little browser testing on my end as well.

Thanks!

Chris Perez

It looks like a security issue. Apparently the source of the video is not from a secure site. However, my FF/Chrome settings do not prompt me to allow the content, so it just never loads. I must have, in the past, accepting the security access in IE, and that's why I don't see that message (because it should also be prompting me to allow).

Someone else in my group was able to see all of these messages pop up. So the problem is solved (sort of). Anyone that doesn't see those messages due to browser settings won't know what to do if the web object page doesn't load.

Thank you for taking the time to help me figure this out, though!