When publishing for LMS, no zip file is produced, just a zia?

I am publishing for an LMS and asking Articulate Presentor to create a zip file. Instead I am getting a file called zia04308 with no extension. I tried it a few times and it creates different numbers each time, like zia12345. And, when the publish is complete, it says that it has published successsfully.

My course contains one flv, no Engage files, and one Quizmaker file. Hmmm, the flv is 21 minutes long. Could that be contributing to the issue? It does publish very fast thought and the course is short.

I read other posts from the other forums, but I do not have the issues that were noted there. For instance, I am not using Articulate across a network (on my C drive), I am using Win 7 / Office 2007, and my course title is only about 20 characters.

I published to a zip file on this same PC just two weeks ago and without any problems.

Ideas?

Thanks, Barb

25 Replies
James Brown

If you have a large hard drive, just create an project folder on the root of c:\ and then inside of there publish your project. That way the path and file name will be nice and short. An option not mentioned was to simply build the project and compress afterward using windows compression.

If you are using Windows Vista or Windows 7, I would just make the project and then right click on the file folder and send it to a compressed zip folder. Anyway just a thought.

Barb Leon

Thanks Gerry and James for your replies. This time, my issue went away by doing nothing except rebooting. I did not change anything in the file/folder locations or renaming files. But your advice is much appreciated and if this ever happens to me again, I will certainly take a closer look your suggestions.

~Barb

Michael Smart

FYI I am having the same problem, and using the Windows zip compression makes a zip folder just fine, but that folder than doesn't work when loaded to my LMS.

Have tried rebooting in various combinations. 4 times it doesn't work, then the 5th time it does.

Has anyone figured out anything new since February?

Thanks very much for any help you can offer.

Andrea Mann-Cooper

Hi, I am having the same problem as the original post.

A zia file is created instead of a zip. From today this applies to pretty much everything I try to zip.

I have rebooted several times but nothing makes any difference. I have the folder (2 digits) saved to my C drive and really short file names and still won't zip.

If I zip using Windows, the LMS doesn't like it.

Anything else I can try?

Justin Wilcox

Hi Andrea.

I am guessing this is related to the location of your project files or the publish location. I would try the following:

  1. Quit PowerPoint.
  2. Create two folders here C:\Articulate and C:\Articulate Publish
  3. Copy the PowerPoint file and its corresponding PPTA file to the C:\Articulate folder.
  4. Open the presentation.
  5. Follow the steps here to publish to C:\Articulate Publish: http://community.articulate.com/tutorials/products/publishing-a-presentation-for-lms.aspx
Please let us know how it goes.
Andrea Mann-Cooper

This is pretty much how I had it but I have created the folders with the names exactly as you say above. I also copied the quiz and the attachment then re-added both from the new location.

Hello zia file. Grrrrr

I've removed both the quiz and the attachment and...... another zia.

It's a small presentation so can't be size and it pretty much happens with anything I try to zip - even those that zipped fine last week.

Justin Wilcox

Can you follow the steps below to get me a trace log of what's happening?

1) Download, extract, and double-click the below trace tool (keep the window open): 
http://www.articulate.com/support/downloads/APTrace.zip
2) Launch PowerPoint. PowerPoint should be launched only after the trace window is open.
3) Follow the steps you normally take to reproduce your issue.
4) When you are finished reproducing your issue, in the Trace window copy the text and paste it into Notepad.
5) Attach the log file to your reply to us for review.
Andrea Mann-Cooper

Testat root of C zips. SUCCESS

Testin same folder as failure above zips. SUCCESS

Testwith Quiz zips. SUCCESS

Testwith Attachment zips. SUCCESS

Test with quiz and attachment failed to zip. FAIL

I attach the trace of the failure.

Then I tried to rezip the Test with Quiz which hadoriginally zipped and this one failed.

It is not dependent on location or the file but appears tohappen at random and then once it happens I won’t be able to zip for a while.

Then once I can zip again, the things I was unable to zipwill zip!

Justin Wilcox

Hi Andrea.

Can you please submit a case here with your log files:

http://upload.articulate.com

Please also include the forum URL when entering your details about the file upload. Once the file is uploaded you will receive a confirmation email with a case number. Please let me know that case number and I'll be happy to escalate your case to my senior level support team.

Peter Anderson

Hi David,

For zip creation to work properly, the full directory path of the publish location needs to be less than 256 characters in length, including the name of the zip file itself. 

Also, please be aware that working on a network drive or publishing to a network drive can cause erratic behavior. You should edit and publish your content on your local hard drive (typically, your C: drive). 

If you continue to experience the same issue, please follow the troubleshooting instructions below. 

1) Try to download and install Winzip utility from this link below. 

http://www.winzip.com 

2) Uninstall Articulate Studio '09 from the Add/Remove Programs. 
3) Download the installer from the link below. 

http://www.articulate.com/downloads/2011/03/Studio-09-Update-8.zip 

4) Extract the installer to your desktop. 
5) Right-click on the Studio-09-Update-8.exe file and select "Run as Administrator". 
6) Install and follow the instructions to activate. 
7) Test your Articulate Studio '09 applications by creating a test file on your desktop and publishing on the same location. Create a zip and see if you still get the same issue. 

camilo jimenez

I have generated many zipped files in the last months and today I only get the zia0218. I only updated my antivirus program but I can't belive this caused the bug.  I have a deadline to meet and this happens now???

Question- when I Unistall Articulate studio will I loose all my player templates?
Thanks

Andrea Mann-Cooper

My problem seemed to go away of it's own accord. Then it came back. The only thing that fixed it was a full reinstall. I've done that twice now.

The zia problem reappeared last month and I just don't have the time to start working through all the fixes again to end up going to a new machine or flattening my current one. I just zip it manually.

Barb Leon

Before you reinstall, try this - works for me everytime. Publish your zip file to your desktop. You can always move the zip to your folder of choice later. I believe this zia error occurs for one of these two reasons: either the file structure is too deep, or the file name is too long. Oddly, if you come back to this course weeks from now, the error goes away completely!

Andrea Mann-Cooper

The file name and location does not seem to matter in my case (though I can MAKE it create a zia by having these things too long so I believe that it may work for a lot of people).

Once mine turns to the dark side it doesn't matter where I publish. Tried desktop, root of C, single letter folders, single letter names etc. It stops working - then the same file, in the same folder, will work again at some point in the future.

For me, once it's happened there does not seem to be a recovery (I spent weeks working through anything I could find that might fix it). So a brand new file called "a" from the root of C will still create a zia.

I work for a large organisation running group policies, desktop authority and preconfig'ed virus protection. I'm starting to think it's something that they (or Microsoft as we get every update forced upon us) switch off an on that causes this problem in Articulate. This ties in with Camilo's post on updating his virus protection.

Ingrid Johnston

Hi All.  Thank goodness for this community!

I had the same problems/deadlines/failed fix attempts discussed above.

Although I work for myself (as opposed to a large corporation) I noticed that there had been an update to my Norton antivirus today which is also when I started having "zia" nightmares...

Switched off the antivirus and restarted the articulate presentation I wanted to package, and voila - a zip file appeared, so I think Andrea and Camilo may be onto something.

Thanks again to everyone