Moodle+Presenter+Quizmaker

Before I go chasing a rabbit down a hole, I thought I'd post this to the community for help. I did search and read some other posts that were helpful, but I am still a bit confused. Well, to be honest, I imagine the more 'technical' aspects of the  Moodle/Presenter/Quizmaker combination to be a rainforest and I am the intrepid explorer wearing  wool clothes and a pith helmet. So while I may find my way in, I might not come out.

I started using Presenter/Quizmaker a few months ago to spice up some of the courses I have built in our Moodle LMS (ver. 1.9.12). I'm now building a blended 5 day course with self-paced lessons created with Presenter/Engage/Quizmaker. The lessons will have no more than one Quizmaker activity and I'd like to be able to report that score over to Moodle.

The attached doc has some screenshots of the Quizmaker properties, publish settings and the SCORM activity settings in Moodle lesson. Quiz is set up for unlimited attempts (though I would like to limit this to 2 at some point for some of the lessons). Moodle is set to unlimited attempts/highest grade as well.

I loaded the published zip, ran through the activity and quiz, closing the activity after each attempt (45/65/100%)but the gradebook is still showing first  (45%) attempt. I've ethe deleted the activity from Moodle entirely, cleared attempts and loaded it again. After the reload, results were 45/65/100%. I didn't close the activity inbetween attempts, I would just check the grade book. Again, only the first attempt appeared in the gradebook.

Am I doing something wrong or have I missed something? Is it a matter of having the quiz in the published Presenter file or should the Activity and Quiz be seperate?

Thanks for the help!

4 Replies
Justin Wilcox

Hi Brady and welcome to Heroes! I would suggest testing your content in SCORM Cloud as outlined in this article to see if you can duplicate the behavior there.

If I am understanding what is happening, you attempted the quiz 3 times in one session and only the first attempt was recorded? See if you can duplicate that outside of moodle and let us know and we can take it from there.

Brady Cole

Justin Wilcox said:

Hi Brady and welcome to Heroes! I would suggest testing your content in SCORM Cloud as outlined in this article to see if you can duplicate the behavior there.

If I am understanding what is happening, you attempted the quiz 3 times in one session and only the first attempt was recorded? See if you can duplicate that outside of moodle and let us know and we can take it from there.

Correct - 3 attempts within the same activity session, delete/reload activity in moodle, clear attempts/gradebook, then 3 attempts (closing activity after each attempt).  With both methods, only the first attempt was recorded.

I'll test it on the cloud. Thanks for the reply Justin!

Brady Cole

Justin, apprecite the suggestions. They have been very helpful!

So far so good at SCORM cloud. loaded my current package (completed/incomplete) and ran into the same issues.  loaded a new version with the prompt to resume on presentation restart and ignore flash cookie removed (Pass/Fail tracking). So far I've seen a new score for each attempt! I'll try the new package in Moodle to see how that goes. We are using Moodle build 1.9.16, so also checking into updating that and will check to see if Moodle LMS is pointing to index_lms.html to launch the course (not to player.html or any other HTML file).

Again, thanks so much!