Quizmaker hangs while publishing

Help! Just come up against a serious problem while doing some updates on a large quiz.

The quiz is rather large, with 108 question slides and about the same number of alternating blank slides, to a total of 226 slides.

Publishing stand-alone quiz works fine.

When I publish into my Presenter course, it runs through all the slides in the publish process, ("Generating"), and then "generating results slides", ending with the Publish window which shows that it is publishing into the Presenter course.

And here it just hangs and does nothing...

Sysinternals tells me that it is using almost no cpu time, but suspiciously it is using large amounts of memory - there are four processes, each using between 211 and 280 MB.

It does not seem to be interacting with Presenter yet, as I can move around in the presentation and even close it without any effect on Quizmaker.

Now here's more: When I cancel Quizmaker, the four processes above are not closed!  I'll try a reboot as well.

23 Replies
Brian Batt

Hi Peter,

First, verify that you have the Communicator add-on enabled in PowerPoint.  This is the add-on that handles the "communication" between your presentation and Quizmaker / Engage.

http://www.articulate.com/support/presenter09/kb/?p=1060

If you continue to have issues, can you verify that the target path to the presentation is less than 256 characters?  If you're not familiar with the "target path", it's basically the amount of characters in the filename plus the location of the file.  Example:

C:\My Documents\PeanutButterAndJelly.pptx

Peter Hers

Hello Brian

Thanks for reply.

I'm ahead of you - already checked all of that.

I proved that publishing a smaller quiz into Presenter does work; also that the problem was not an issue with the PPTX/PPTA, by obtaining the same non-result trying to publish into a new one-slide presentation.

Also checked the path length, as I know that has been a problem for Articulate in the past.  Windows 7 can give one very long paths, but mine was only 125 bytes.  I do recall a case where the limit seemed to be 128 bytes, so I moved the whole project to obtain a shorter name, but the problem was still there.

It's strange, as this quiz did publish successfully a couple of months back.  But I've been doing a lot of editing on the slides, so perhaps something has changed (although most of the edits made it simpler!)

I've now produced a work-around, by dividing the quiz into 3 sections, and running them consecutively. (Previous suggestion somewhere in the old forum).  The downside is that I now cannot publish an overall result at the end.  Also one cannot make this totally transparent to the student, as question numbers restart for each section, etc etc.

So it looks like my quiz is just too large.  I know this has been a problem in the past, but I really wish Articulate would clean up the many failure points in Quizmaker.

I have not tried re-installing the whole Articulate suite - This helped once a or twice in the past.

Unless there are any other suggestions?

Brian Batt

Hi Peter,

I would suggest you submit a case by following the steps below.

Please create an Articulate Presenter package, then upload the zip file to our server. You can review how to do this here: 

Send to Articulate Presenter Package – Articulate Presenter ’09 Help

Upload the resulting zip file from your computer to our server using this upload form: 

Articulate Support - Upload Your Files for Review 

Please be sure to include a description of your issue, your version of PowerPoint, version of Windows and version of Presenter '09 which you can find in Help and Support -> About Articulate Presenter. Please also include the URL for this thread so we can follow up with you in the forums.

Jeney Rodarmor

I am having a tough time with a similar problem. I've edited a course that's been working fine.  Now my final quiz just hangs.  I checked the settings per the suggestions above, and they seem fine. PS this quiz works fine when I preview it.  I also created a 3 slide presentation and embedded the quiz and it published without a problem.

Any help would be appreciated.  Today's the deadline for this project!

Jeney Rodarmor

Hi Peter,

Actually, the problem occured when I attempted to view the published course before uploading it to the web server.  Interestingly, I could preview the quiz (and the slide preceding it) without a problem and it worked fine.  But the published version hung.

Yesterday, I tried one more thing:  I copied the entire course to another PC that is actually networked (the development PC is a stand-alone laptop).  And it worked!  I'm thrilled.  I don't understand what happened.  Could it be that the stand-alone PC hasn't received any patches or updates in a while?

Reese Radcliffe

I was having the exact same problem as those above, but things have gone from bad to worse.  I had a presentation with ~250 slides and 7 quizzes.  Worked fine in all aspects - preview, local, publish to LMS.  Changes were required to the content, and then all of a sudden the preview and local copy worked fine but the LMS version wouldn't load the quizzes.  I tried everything suggested above (also received as a response from Articulate support) to no avail.  I even tried rebuilding the course from scratch in a new directory and uploading to a new directory with no luck.  Then I removed all the quizzes, saved the ppt, and then added just the first one.  Now I can preview the slides and it works fine, but now the local version won't even work!

There is a ticket open with Articulate, but not being Premium, I'm sure I'm not very high in the queue.  If anyone has any ideas, PLEASE HELP - I'm missing deadlines!!!!

Here's Johnny!

Reese Radcliffe

Thanks to all - I really appreciate the quick replies and support of the forum!

Okay, so Peter - when you say upload my files here for you to look at, are you referring to the mechanism as identified by Brian's post earlier in this thread?

As an update, and based on Jeney's feedback, I had an idea.  I took the course that's hanging at the quiz, started a new file, and just copied over the slides for section one and then added the quiz.  At this point, I'm not even trying to solve the LMS issue anymore - even with trying that I can't get the quiz to load locally now.  I even opened the quiz and re-saved it prior just to make sure I had a clean save of the quiz.

Reese Radcliffe

Quite alright, Peter - thanks for your help.

I think I'm onto something, though, so let me continue before I waste your time.  I know one of the parameters is the full path to the presentation, and that it is set to 256.  I was very careful to follow this, and while my full file path length is a ridiculously long 185 characters, I figured that since it was below the 256 limit I was okay.

I have since changed into a test environment with a ridiculously short path/file length and the quizzes now load just fine.  I'm uploading to the LMS and will let you know if that works.  Given that it's the only thing that I've changed, I have high hopes.  The only thing I can say is I really hope this fixes things as it then becomes an easy fix.  On the other hand, while there is clearly a path length restriction, it seems to me as though it's some unknown less than 256.

Just sayin ...

Justin Wilcox

Hey Reese. Glad you were able to narrow down your issue. Directory path length is not something one usually thinks about but can cause issues with software. I've solved more than one issue by simply asking people to create a folder at C:\Articulate and put their projects there. Often solves many a problem. 

Reese Radcliffe

To close this out, the path length seems to have been the issue.  While we did have ridiculously long filenames, we were still well below the 256 character restriction.  So, problem solved - YAY!  (And thanks for everyone's help).  As to the specific path length number, while I don't know what it really is, moving forward I'll just keep them as short as possible.

My guess is that somewhere in the Articulate code that performs the flash conversion, there's a variable somewhere that should be dimensioned to 256 but it's not and the filename is then truncated and as a result it can't find it.  Either that, or every system I try this on (including SCORM Cloud) has some buried and hidden directory structure eating up the other 97 characters that I don't think I'm using.

Regardless, we're working again, and it's all good.  Thanks again to all!

Here's Johnny!

Reese Radcliffe

BTW, Jeney - I suspect that is what solved your problem, too.  When you copied to another system, your directory structure was likely different as well, and perhaps the new system resulted in a path length shorter than the stand-alone development system.  Looks like that's what solved Peter's problem as well (thanks for the feedback Peter).  Just a guess, Jeney, but I'm happy we're all working now.

Perhaps the path/file length troubleshooting technique should be moved up higher in the Articulate resolution queue for users exhibiting these symptoms.