508 Compliance: Can't use Enter to select buttons with Visited state.

I found this in an article elsewhere, and it saved my hide on a fairly large gov't project. If you find that you are unable to use the keyboard "Enter" to use buttons on a project created in an earlier version of Storyline, it's because you have to remove the "visited" state.  This can persist, even when opening older files in updated versions of SL3 or 360. 

6 Replies
Sam Hill

Hi Miles, I tried to replicate this issue and wasn't able to. Is it a particular browser that this issue affects?

Here's the demo file: https://360.articulate.com/review/content/0c8191ad-bddc-40fe-aa43-79f1a5b8e443/review. I'm just toggling a variable, which is in turn updating the state of a shape. The visited state on the button is purple.

I'm on the August 18 update of SL360.

Sam Hill

Hi Miles, I tested in Preview and using Chrome outside of the Review 360 environment. No problems for me: https://360.articulate.com/review/content/f84d0186-8125-4f47-8cbb-b4b0372f6542/review

I've also confirmed it is working as expected in Edge and Firefox latest.

Maybe if you could create a demo I can test from my side? It seems unusual to be getting such different results. 

I'm using SL native buttons, is this the same set-up as you?

Miles Carr

So, gentle readers... I just tried this with a new project, and also had the same results that Sam did. Enter button worked like a champeen. It may just be a problem with a project made with an older version. Even though my SL3 is up to date, it must have carried over that problem from an earlier iteration of SL. Couldn't get the button to work with a keyboard until I took out the visited state. Bizarre. The oddest thing is that even new buttons had the same issue when added. Unfortunately, I can't hand the file over. Hours of heartache, I tell ya. Well, I'm glad to see that's addressed. Updated accordingly, above.