A video cannot be inserted from this embed code.

Update: I still have SL1 on my machine so I copied a code SL2 rejected, and SL1 took it with no problem.  I really need to figure this out.

----

Can anyone tell me what the requirements are for an embed code? We're using the same videos on the same servers that we've been using for years. In SL1, no worries--we used the embed codes from our media server and had no trouble. Before we switched to SL2, I tested out the video feature to make sure we could embed the same way we always did, with no trouble. As of a couple of weeks ago, I could.

 

Here's an example of a video I embedded a couple of weeks ago that worked fine:

 

<iframe src="https://w.kontiki.com/laquinta/player/2f1eddaf-fd6f-4d0e-886e-42a0d0b49df6?params=MD10cnVlOzE9NTM7MTI9dHJ1ZQ==" style="border:none;width:100%;height:100%" scrolling='no' allowfullscreen></iframe>

 

NOW, when i go and try THAT VERY code, I get this message:

A video cannot be inserted from this embed code. Verify that the embed code is correct and try again. 

What changed from a couple of weeks ago? I recommended SL2 and we upgraded based on many tests, including embedded video. There is simply no reason it shouldn't work today.

 

 

 

 

 

 

 

 

130 Replies
Ashley Terwilliger-Pollard

Hi all,

My apologies. I misread the issue that was filed with our QA team - it was filed in conjunction with SL2. It worked as expected in SL1, and if you upgrade a file from SL1 to SL2 the embed code still works, but when adding that embed code directly in SL2 you'll see the error message. This thread is linked within the existing QA report, so that we can share any updates here when available.

Ashley Terwilliger-Pollard

Hi all,

Just to update this issue, it seems that Storyline 2 is requiring height and width attributes rather than allowing the CSS styling supplied in the embed code. This is still with our QA team - but if you're able to share the code here, we may be able to assist in updating the code. 

Joe Stoup

Ashley,

Thanks for the information! That allowed me to keep our project moving. For reference, here is the code that I had to use to get it to work:

<iframe Width=800 Height=600 src="https://w.kontiki.com/xxxxxxxxxxxxxxxxx"></iframe>

An interesting note, I had to remove the quotation marks from around the Width and Height parameter. Apparently, Storyline 2 auto inputs the quotation marks. 

I started with this from Kontiki:

<iframe src="https://w.kontiki.com/xxxxxxxxxxxxxxxxx" style="border:none;width:100%;height:100%" scrolling='no' allowfullscreen></iframe>

I hope this helps someone else experiencing these problems.

 

Joe Stoup

Hi Patricia,

If you take my code and just replace the link with yours, it should work. I replaced it below for you to test.

<iframe Width=800 Height=600 src="https://w.kontiki.com/laquinta/player/51bce2a2-a650-46c6-8b09-40dd1e073dde?params=MD10cnVlOzE9NTM7MTI9dHJ1ZQ=="></iframe>

If that works, going forward you would just have to input the Width and Height parameters and delete everything from style to the >.  Hope that helps.

Terry Springer

How about this one?

<iframe width="560" height="315" src="//www.youtube.com/embed/NcqYkr_mHh4" frameborder="0" allowfullscreen></iframe>

I get an error message when I try to insert it into SL2. I was able to insert it yesterday but when I restarted my computer it wouldn't take it today. All of the update are current.

Ashley Terwilliger-Pollard

Hi Terry,

What you listed before that I dropped into my Storyline file is a bit different - this is what I used:

<iframe width="560" height="315" src="//www.youtube.com/embed/NcqYkr_mHh4" frameborder="0" allowfullscreen></iframe>  comparing it to your first image, you'll want to look after allowfullscreen and remove the equal sign and quotations. 

Ashley Terwilliger-Pollard

Thanks Terry - I see that now, I hadn't gone back to check the embed code after inserting it and just published to test that out - but in my version I still don't see the error message that you're reporting here. Is this happening with all videos you try to embed? What update of Storyline are you using? 

Kami Madsen

I am fairly new to using SL1 and SL2.  I created a project in SL1 and I am getting this error message:

Error: This page has been unpublished.  Please notify the Video Portal Administrator.

This message appears before I publish and also appears in the published version via an LMS.

I work for a state agency and started asking other colleagues if they have encountered any issues at their agencies.  They had not received this particular message but said they had some people who could insert a video and others who could not.  The other route I took was to find a random video from YouTube and try it in my video's place.  When I did that, I encourntered the  video cannot be inserted from the embed code error message and couldn't move forward.  I just upgraded from SL1 to SL2 in hopes the video embed issue would be resolved.  I'm still getting the unpublished error message.  I'm not sure if it's a firewall issue or just a bug. 

After looking at suggestions in the string, I played with the embed code taken from the site I'm tyring to add the video from and still get the above unpublished error message.   

The code I'm trying to use from their website is:  
 <iframe
 style="width:640px;height:442px;"
 frameborder="0" scrolling="no"
 src="http://www.irsvideos.gov/ifp.aspx?node_id=507"
></iframe>

The site offers a URL to link to, but when I tested that in SL1, it opens in a separate window and the learners would have to close that window to get back to the training.  I am trying to avoid extra steps by embedding the video.

Any suggestions/help will be greatly appreciated. 

Ashley Terwilliger-Pollard

Hi Kami,

In regards to the error "This page has been unpublished" I haven't seen that before and it sounds like an error with where or how the video is hosted? 

Here is another thread where a user was having difficulty with embedding videos - and the answer I shared there you should still be able to test that here:

I just grabbed a random embed code from YouTube here. (It's the Tonight Show with Jimmy Fallon - one of my favs). You'll want to make sure you use the "Share - Embed code" and capture all of it, and then insert it into Storyline using the "Insert Video from Website" to be able to insert that code. 

I uploaded a copy of it to Tempshare and it all works fine for me. 

Clicking on the link you shared above, prior to even inserting into Storyline I receive that error message which indicates again it's something with how that video is hosted.

Kami Madsen

Thank you so much for your response. I still encountered the embed error even using the video you recommended. I called my IT department to see if I was fighting some type of security block and they are also looking into the issue. They put me in a Bypass (their term) to test again and I am now having success. They said they will continue to dig further on their end.

Thank you so much for your help!! It is baffling that some people have no problems while others do. My assumption after calling my IT department is firewalls/security levels can prevent some users of Storyline to embed videos.