Accessibility of videos embedded as web objects

Hi there.

From my testing, when I embed videos as web objects into storyline files, the controls for the video are not keyboard navigable, and I can't get it to start playing with keyboard controls. It doesn't seem to matter whether I have the video set to start automatically or when clicked. See attached, and also at https://360.articulate.com/review/content/abdf4f7a-042c-482f-b86e-a0a2a8bc6348/review.

Anyone have any solutions?

 

36 Replies
Brian Dusablon

My issue is a bit different here. I have embedded Vimeo in a course, and can tab into the web object, but then I cannot tab OUT of the web object to get back to the main navigation of the course. Any tips? Any updates here for tab order within Articulate? I should be able to tab through all objects on the screen, when I get to the web object, tab through all objects within it, and then tab back to main controls (similar to how browser controls work), no?

Brian Dusablon

Are you using Storyline 360? Yes.
Is your Player turned off for a chromeless experience? Yes.
Are you viewing in Chrome or another browser? Chrome, Safari

Steve Flowers tested this also:
"It seems that if the menu is turned on, tabbing behavior works as expected. If the menu is off, the cursor gets trapped. Not sure why this is happening. But it seems to happen in both the modern and classic player."

We use our own navigation, so having to use the Articulate menu is not an option.

Erich Renken

If my memory of this is correct, my workaround was using "invisible" (shapes with no fill and no lines) buttons in SL that used JavaScript to interact with the Vimeo API. So, I wasn't tabbing into the video (where focus is trapped). I was interacting with the video using SL triggers and JavaScript. I ultimately didn't use this solution, though.

Jenny Najduch

In case anyone is still wondering about this, I found a weird workaround - 

Brian mentioned that you can tab out of the video if the menu is on - same thing works if the resources tab is on in the player. I don't have resources, so I just erased the resources text in the "Text Labels" on player settings so you can't actually see the tab (if you click up there the box still opens, but unlikely someone will click this tiny little blank space there).

You can also turn the resources on for only slides with videos - that's a slide by slide option under Slider Properties in Story View.

Not sure why it works, but am overjoyed that it does! Thanks for mentioning the menu, Brian!