Articulate 2 Background Color does not save

I noticed Articulate 2 has an issue saving the background color on project files. Please let me know if anyone else is having this issue. Here's the steps I take:

  1. Create blank project
  2. Change the background color in HOME/PLAYER/COLORS & EFFECTS/BACKGROUND COLOR
  3. Publish project to see the color of the background
  4. Save and Close the entire program
  5. Reopen the saved file
  6. Publish
  7. Check the background color (you'll notice it defaults back to white)

Thanks in advance!

13 Replies
Emily Ruby

Hello Ed!

I tested this in SL2 and the background color did save.

this is the published output of the file after re opening it: same color i changed it to.

If you continue to have this issue you could follow the steps here, and also make sure you are working locally as described here.

you could also attach the file here if you would like us to take a look.

Ed Gen

Hi Emily,

Below is a screen shot with a blue background color. After I set the blue background, I publish the course and test by viewing project (works fine). I then save and completely close the entire Articulate program.

Then I reopen the story file and immediately publish without clicking around the tabs and view project again. This is when I noticed the background color reverts to the default white background as shown.

Attached is my story file.

Emily Ruby

Hello Ed!

i checked your file, and again I am able to see the blue background when saving and reopening.

I tested this by publishing to LMS, on the SCORM Cloud, are you using a different way to test the publish course? I saw in your file it was set to publish for LMS.

Be sure to view your content in its intended environment. If you published for Web or LMS, upload your content to a server for proper viewing. If you're viewing content locally, publish for CD, then double-click the Launch_Story.exe file. Otherwise, local security restrictions in your computer and browser will cause various features to fail.

Ed Gen

I believe Autosave is the issue.

Basically, while autosave was turned on, the background color defaulted to white every time I republished an existing course file. Then, occasionally when I try to publish a course, the progress bar window would not appear and the course would get stuck/freeze causing me to forcefully end-task.

After turning Autosave OFF, the background color is retained and so far haven't had any issues with the program freezing yet. I'll continue to run tests and post any updates.

Diana Myers

@Ed - you're my HERO!!!  I've created two MAJOR projects in SL2, and on both I've experienced the horrible "freeze ups" when trying to publish; on the second project my customized black player background kept defaulting to white...  ACK!!!!!  

(see attachments - customized player, 1st output (bkgd changed to white), and 2nd output after turning off autosave)

Thanks so much for the tip to turn off autosave - you totally saved me on this!!!!  #ILoveThisCommunity

Ashley Terwilliger-Pollard

Hi Diana,

It sounds like you may also have run into an issue where if you change the page background color in your course player to something other than white, you may find that it's still white when you publish your course.

This is a known issue that can occur after closing and reopening a project file. It'll be fixed in the next software update for Articulate Storyline. In the meantime, here's how to avoid this behavior:

  1. Before you publish your course, go to the Home tab on the ribbon and click Player.
  2. When the Player Properties window opens, click Cancel to exit without making any changes.
  3. Publish your course.