Articulate 360 Browser Specs/Requirements

I saw a staff member respond within another thread about someone having issues with IE11 and the content library.  The response pointed to the system requirements.

I can no longer figure out where I saw this posting.

Can you share the link(s) for system requirements for Articulate 360 and the tools within?

1 Reply