Articulate 360 Not Completing Sign In

I tried to run Storyline 360 today and I can't get past the splash screen. It says "Signing in to Articulate 360..." but never finishes. I then need to close that screen by using Windows 10 End Task.

I have tried:

- restarting laptop several times

- launching from taskbar shortcut, from a .story file, and from the Storyline.exe file with same results

- signed out and back in again at Articulate site, same results

- reinstalling Articulate 360 from downloaded articulate-360.exe file, only to be told that "Articulate 360 has already been installed"

Would love a solution so I can get back to work.

Thanks,

Jeff 

12 Replies
Ashley Terwilliger-Pollard

Hi Ralph,

It looks like you have a couple different Articulate IDs and your trial was started with a different one (ralph@) than what is connected to your Team subscription (ralph.pichie@). Can you try logging out, and log back in with the email address that beings with ralph.pichie@ and let me know if that works? 

Alyssa Gomez

Hi April!

In yesterday's Articulate 360 update, we refined processes behind the scenes to prepare for upcoming improvements to our sign-in experience. You'll be prompted to sign back in to the Articulate 360 desktop app after installing this update. 

You may need to ask your IT staff to allowlist id.articulate.com so you can sign back into Articulate 360. Learn more about network endpoints that need to be allowlisted here.

Please keep us posted, and let us know if you need more help!

Ashley Terwilliger-Pollard

Hi Eric,

We had an issue earlier this week that prevented some users from logging into the Articulate 360 desktop app, but that has been fixed up. It has been quite rare that we've had an issue of this type, so if you're running into an unresponsive Sign In form consistently I'd like to have you work with our Support Engineers to take a look! 

If it's only been an issue this week, please look at force closing out of Articulate 360 and restarting the application. Those steps did the trick for others this week: