23 Replies
Ashley Terwilliger

Hi Kai,

Yes, as Emily mentioned up above, you would need to have inserted an MP4 that matched one of those profiles - and then you could use the uncompression setting. If you think you have a video which does match that set up but that it's still not working as expected, please send it along to us so that we can take a look. You can upload it here. 

Ashley Terwilliger

Hi Kai,

What I've done in the past is reconvert the video using HandBrake (http://handbrake.fr/), which is a free tool. Here is a video screencast on how to use HandBrake to convert videos to be used with Articulate software. 

Depending on the software/program you used to create the video, you may also be able to see the profile within that software and adjust as necessary. 

Dominique D

Hi,

 

I also have the same problem. 

I produce my videos with ScreenFlow and made the test with both the main and baseline profile.

I still can't change the compression setting in Storyline.

I use this professional video editing suite for various productions. In this case I need a picture in picture video. The min and "in picture" videos have good quality in the MP4, but the "in picture" one is ugly in Storyline.

Jesse Friesen

Hi Ashley, 

I realize this is an old thread, but I've been experiencing this issue with a series of short videos I need to import into Storyline 360. Seemingly at random the videos will have the Compression option greyed out as "automatic". I've already tried using HandBrake and following the steps in the video you hyperlinked. 

That workaround seemed to work for one of the videos, but all the other ones are still coming through as greyed out. I am kind of at my wit's end for how to solve and have already devoted several hours to troubleshooting with no luck. Any additional advice would be appreciated!

Katie Riggio

Greetings, Jesse!

Sorry to hear you're at this obstacle, and I'm with you: So odd that the re-encoding with HandBrake solution helped with one video, but not the rest.

We're happy to lift the troubleshooting boulder off your shoulders. Would you mind sharing one or two of the troublesome video files with us? You can send it to us privately by using this upload link. We'll dig in, and will delete the file after testing!

Gabriel Butler

So I am facing the same issue. I have videos in my storyline project, all of which have the Compression dropdown menu grayed out. I want that menu "active" so that I can select the None option (I do not want storyline to compress my videos at ALL, and instead, leave them at their full resolution when I publish).

I do not want to use Handbrake. I want to know the exact export settings I should use in Adobe Media Encoder so that the resulting video(s) will not gray out the Compression dropdown in Storyline. Please see the attached screenshot and let me know (field-byfield) exactly what each export setting should be. 

Flavio Fulciniti

I think this option in Articulate is a little bit buggy.
I use the same handbrake setting to convert file (see attachment). Sometime the file works (and compression option is available in SL360) sometime not.

In other cases the same file doesn't work in a project and works if I create a new storyline file... where is the problem guys?

I also attached here a video that dimostrate this.

The "no compression" option is very important for projects based on video because I can control final video quality and prevent recompressions but it works randomly! This is a bit frustrating in my professional work and it would be nice to know, technically, what I'm doing wrong.

 

Elizabeth Li

I was experiencing this too when trying to replace existing videos with new videos. 1 out of 10 videos allowed for the "Compression - None" option, the other 9 had the option grayed out. After many hours of troubleshooting, I was able to resolve this issue using the following workaround:

  1. Delete the mp4 video from the Storyline file.
  2. Save the Storyline file. 
  3. Close the Storyline file.
  4. Reopen the same Storyline file.
  5. Insert the same mp4 file into the Storyline file (Insert>Video>Video from file...).

Like many others, I tried other workarounds that did not work. This included re-exporting the videos from Camtasia with different export settings, converting the video using VLC and Handbrake, exploring different codec options, adjusting file dimension sizes, renaming files, trying different file locations, etc. 

I don't know why this workaround works...but I hope this helps someone. 

Paul Colby

Storyline is one of the worst pieces of software I have ever used. There are sooooo many of these types of issues. Of course, the Storyline staff always gives you the most obvious recommendations, such as using the correct video profiles, blah, blah, blah. They never stop to think for a minute that it is their garbage software causing the problem, not anything that the users are doing.

I am a professional software developer, have been doing it for 28 years. I know my stuff. I was having this same issue. I would encode videos using Handbrake with a saved preset, so I know they were all compressed exactly the same way. When importing, sometimes the "NONE" compression option would be available, sometimes not. It seemed fairly random. Replacing a video with another video definitely seemed to cause the issue more often than not. What b.s.

Long story short, Elizabeth Li's method works. Delete the video from the timeline. Save. Close Storyline. Import the SAME EXACT VIDEO  that wasn't working. Voila, it works, no the "NONE" compression option is available. Unbelieveable!

Having read all of the comments on this issue, I see that Storyline staff is still telling users what profile to use for encoding, use Handbrake, upload your files so we can look at them, etc. Often, one also usually gets the infamous "Here is a link for you to submit a feature request." Egads! It's your garbage software. Fix it!!!!!