Audio dropping out of sync in HTML5 course

I built a regular HTML5 course in SL360, and published for LMS.

Each slide has at least one mp3 file for VO which the onscreen visuals are then synchronised to. Some slides have multiple VO files one after the other on the timeline.

Unfortunately when viewing the course, sometimes the audio will drop out of synchronisation and the last 1 or 2 seconds of an audio file are cut.

For example, if the VO was supposed to say "Point 4, wash your hands." then you might hear "Point 4, wash yo..." and then the course moves on to the next slide.

The problem seems to vary in severity from browser to browser.

It also happens when just running the course from a web server and not an LMS.

Doing some research and reading, it seems its a known HTML5 issue, especially when the browser window loses focus (ie. user switches to another tab/application)

 

I know Articulate just patched SL360 in December, and one of the patch notes mentions this issue, but the patch doesnt seem to have helped for me.

Has anyone else experienced this issue, and is there anything we can do to mitigate it?

Thanks.

3 Replies
Alyssa Gomez

Hi Andrew! 

It sounds like you're experiencing a problem that's a little different than the bug we fixed in December. It's helpful to know that it happens on both a web server and a LMS, and the severity varies from browser to browser. Which browser seems to give you the most trouble?

I'd like to test your file, if you don't mind sharing it. Could you attach a copy of it here?

Dayn Wilkins

Hi 

I'm seeing this problem too. I've been using Storyline since V1 and I've never noticed this in the past (apart from known issues synching objects with video in Flash output).

I've just upgraded a module from SL2 to SL360 which I'm now publishing in HTML5 format only and I'm experiencing quite random synching issues. I've definitely noticed this happen when the browser loses focus and you then return to it, as mentioned by Andrew. 

Also, when there's more than one audio clip on the timeline, the second clip will sometimes start playing before the first is complete (even though they're spaced apart on the timeline). I'm getting to the stage where I'm considering merging the audio clips together and adding long sections of silence to try and preserve synching with other objects.

I've also had audio truncated at the end of the slide, as mentioned by Andrew. But if then if I play the slide again, it will often be OK.

Ashley Terwilliger-Pollard

Hi Dayn,

I'm sorry to hear you've run into such trouble syncing your slide animations, especially upon upgrading a file! 

Would you be able to share one of these course examples with our team so that they could take a look at how it's behaving? If so, please upload it here and once you do so let me know as I'd like to follow along as our team tests it.