Audio issues on tablets

Hi everyone, 

I'm writing here 'cause I can't figure out how to solve this problem and I couldn't find a thread in the forum that could help me.

I upgraded a few courses from Storyline to Storyline 2 to better perform when viewed on tablets, but I am still having troubles with audio: it sometimes stops working and the only way to get it back is to reload the course. Since all the slides have spoken commentary this is a serious issue for our client and we need to fix it.

This issue appears to be randomic, except for 2 particular slides, both placed right after a slide with a video embedded, where the problem occurs all the times. I checked those slides to see if there was something different or wrong but they were just like all the others. 

I tested these courses on an Ipad2 with Safari and on an old Android tablet with OS 4.2 and latest Google Chrome version. The courses are published as LMS and hosted on a Moodle 2.7 based platform (uploaded as Scorm). The problem occurs only on tablets, on PC the courses work just fine.

I hope I made myself clear (english is not my mother language) and I hope that someone can help me.

Thank you.

Andrea Gola

5 Replies
Ashley Terwilliger-Pollard

Hi Andrea,

Are you using the latest update of Storyline 2? There were some recent fixes that dealt with audio in Chrome and Safari on the Android/iPad tablets. If you are using Update 7 to publish these courses and still experiencing odd behavior, we'll want to take a look at your .story file (even if you can narrow it down to those problematic slides) and you can post it here using the "add attachment" button. 

Andrea Gola

Hi Ashley, 

I used Update 7 to publish the course.

I am attaching half of the real course here, I tested it just now and I had the same problem, this time on slide 1.33. I preferred to give you a large part of course because the problem it's randomic, except for what I wrote above.

Thank you.l

Ashley Terwilliger-Pollard

Hi Andrea,

Thanks for sharing the course. I published it using Update 7 and uploaded to my SCORM Cloud account here. I tested it on my iPad mini running iOS 9.1. I didn't hear any issues with the audio, and only found the one video slide which didn't play right away. Was that part of the issue you experienced?I tried jumping around (and disabled the restricted menu so that I could do so) but could you take a look at this version and let me know if you're able to recreate the issues with the version I published as well? If so, let me know if it's still random or specific slides. Also, please let me know which iOS you're using. 

Andrea Gola

Hi Ashley, 

I was able to recreate the same problem on your version too, unfortunately. I stayed on the slide "Contatto fisico e comunicazione" (1.21) for a minute or so, then I struck the "Succ" botton twice (cause I didn't understand if the first time had worked or not) and then from the next slide on the audio track was completely mute (I checked both the volume of the Tablet and the volume in the player and they were ok).
 
It happened again with a similar behaviour on my second try, this time on the 1.11 slide. Again, I waited 1-2 minutes and then I stroke the "succ" botton twice. Again, no audio on the following slide.
 
I had the same issue on my version: if you don't proceed immediately to the next slide or if you strike twice on the next button sometimes (not always) the audio doesn't work anymore from the next slide on, if you don't refresh.
 
As for the video slide, always played well to me. The problem is in the slide next to it: once again, no audio, even though it's there in the project and if you reload it works again.
 
I am testing this course most of all on Android because it's the OS that our client will use, but i double checked it on my Ipad 2 with IOS 8.3.
 
This is not the only course in which I experience this issue.
 
What could be the problem, in your opinion?
 
Thank you very much for your help.
 
Andrea
Ashley Terwilliger-Pollard

Hi Andrea,

I followed your exact steps and still didn't run into any issues. The slide audio began and kept playing upon reaching the next slide. I did notice looking at your slide triggers that it's set up to advance to the next slide when the user clicks if a variable is True - but I don't see anywhere that you're adjusting that variable? I can also see that you're using the menu option of "restricted" (which as I mentioned I disabled in the version I published) and when that's enabled the user won't be able to use the next button to advance until the slide timeline has finished - although the button will still look and act as if it's clickable. 

It may be that I'm using a later version of iOS than you and I don't have 4.2 on my Android either (I'm on 4.4). Are you able to look at updating your iPad iOS to see if that resolves the issues?