Audio on 'Next' doesn't seem to work in Preview Scene or Project mode

Hi, I am using Storyline 1... I have set up audible 'clicks' to play when my user clicks next or previous. The triggers work in 'Preview Slide' mode, and all seems well. BUT; When I preview in Scene or Entire project, the audio clicks are absent. This is strange because other clicks such as on hotspots or objects are working just fine. I have checked that my triggers are at the top of the trigger list, and I know there is nothing wrong with the audio files because they are working elsewhere in the slide perfectly well. For some reason, they just do not work with the Next or Previous buttons in the Preview Scene/Project mode.

If anyone has a workaround for this, I'd be grateful. I am hoping to upgrade to Storyline 2 later in the year, assuming that this is a bug that has been fixed.

Appreciate any help...

Kelly

 

17 Replies
Wendy Farmer

Hi Kelly

I see what you mean...I wonder if it has something to do with 'copied audio'.  I found this in one of the tutorials: - hope that helps

Here is the full link

https://en-au.articulate.com/support/storyline/how-to-add-a-sound-effect-to-a-button-click

If you want to add the same sound effect to more than one button on the same slide, you'll need to import the same sound file for each button.

Kelly Bardsley

It would seem that way, but I have various other copied audio files in there that are working fine. I have another storyline file that is bahaving like this - it has quizzing slides in it, and the 'copied' audio files work fine when you click 'Submit' - but not when you click 'Next' of 'Previous'.

Thanks for your help anyway :-)

 

Kelly Bardsley

Thanks Ashley

I have replaced all the copied audio with source audio and still it does not work. Clicks in the interactions are working fine though. I am exporting to html5, not sure if thats a problem. I have uploaded to my LMS and tested on an external device also, still no 'Next' clicks.

I've attached the amended story file, appreciate any advice :-)

Ashley Terwilliger

Hi Kelly,

Thanks for sharing the file here with us. I see the behavior even while previewing, that the "click" sound is never heard. I think the click sound isn't being heard as there isn't time before jumping to the next slide.

So there are two options:

The first, and easiest is to set a trigger to jump to the next slide when the media completes for the Click sound - you'd need to add additional files for the other times you need the click sound to happen though. 

Or you could set it up to show a layer when clicked, and the layer automatically jumping to the next slide when the timeline starts. I did this on slide 1.3 in the attached copy (removed a few other slides that didn't have the sound for testing purposes). 

Hope that helps and is easy enough to replicate for your other slides. 

Kelly Bardsley
Ashley Terwilliger

I see the behavior even while previewing, that the "click" sound is never heard.

Hi Ashley,

If you go into any of the slides and preview 'This Slide' only,(not the Scene or Project) the clicks can in fact be heard...that is why I am so confused. Storyline seems to be reading the triggers correctly...

Kelly

Kelly Bardsley

Hi Ashley,

Thanks for submitting the amended file. I have had a look at it and what you have done does seem to solve the problem. I have looked at the file and tried to replicate what you have done for the other slides but I don't think I am doing it right. (I have created a blank slide layer on each and added a trigger to 'jump to next slide when timeline starts?)

Also; what happens when you want a 'click' noise on 'previous' ?

Could you be a gem and just write a step by step for each of the methods you have suggested plus 'Previous' so I can try them both please? I am perhaps using the wrong triggers...?

Please see my attempt attached.

-----Does this problem occur in Storyline 2?

Kelly

 

Phil Mayor

As Ashley says this isn't really a bug it is a design issue, the triggers fire in order and it is jumping before it has time to play the audio. The triggers fire in order in fractions of a second so there is no time for the audio to play.

You need to change the next slide trigger to be as Ashley suggest to jump to next slide when media completes and choose the audio on the next button (this would need to be different audio from your other clicks).  Or add a layer with the sound on and set a trigger on your next button to show the layer and then set the timeline to be the length of the audio and add a trigger to jump to next slide when timeline ends.  

For a click noise on previous you would need to do something similar, it is a lot of work.  The simple way is to get one slide working and then duplicate it.