Audio Plays in Audio Editor, but cuts out in Preview and after Publishing

Hello,

A coworker recorded audio for all slides in a Storyline project.  The audio plays fine in the audio editor, but on almost every slide, it cuts off after a few seconds.  There are no triggers, buttons, or anything like that on the slide.  This is pretty much just a PowerPoint with audio done in Storyline project.

He recorded it in SL 1 and I opened it an made some slide edits in SL2 (we do this a lot), so I would prefer not to ask him to re-record.  Any ideas, please?  I haven't run into this issue before.

Thank you in advance!

Della

16 Replies
Christie Pollick

Hi, Della -- Thanks for reaching out and sorry to hear of your troubles! May I ask if you have had a chance to test the published output in the intended environment to see if you are finding the same behavior there, as well? If issues persist, you are welcome to share your file, and to do so privately, here is the form you would need.  

Della Gerometta

HI Christie,

Yes, it was in our LMS where the issue was discovered.  I think I have fixed it, although the fix doesn't seem to make sense to me, so maybe you could give me some insight, please?

Probably 75% of the slides had the issue.  You would click to the slide, the audio would start to play, and then cut out.  The seekbar would continue, but no sound.  When you listened to the audio in the audio editor, it played all the way through.  The timeline did not end before the audio track.

I exported the audio files on the affected slides and saved them as MP3s.  I then inserted the new MP3 file and deleted the original audio file. Voila, it worked.  The audio played through in preview mode, and in the LMS after publishing. 

Any ideas?

Thanks so much,

Della

Christie Pollick

Hi, Della -- Thanks for your reply, and since you have now addressed the problem in your file, it's hard to say for sure where the issue was taking place. May I ask if you can confirm that you are working locally as described here? Perhaps there was an element of file corruption as the article states, "Working on a network drive or an external (USB) drive can cause erratic behavior due to latency, such as file corruption, an inability to save changes, and loss of resources."

Joe Brotka

We are having the same audio issues when updating existing SL2 projects. These were created in a SL2 version prior to the last SL2 update. 1 or 2 slides will have the audio cut off after publishing. (yes all were published locally) To correct the issue, we just opened the audio on the affected slide in the audio editor, let it play through and then closed the editor without saving changes. The audio was encoded again without issues when previewing it and the published version worked fine. The slides were not updated for content as we are only applying a logo change to the Slide Master. When previewing the project before it is published, all audio on all slides work fine. It is only after publishing that the issue appears. It seems random as the audio tracks range from 20 seconds to 2 minutes and the cut off occurs at the end of a sentence or in the middle of a word.

Crystal Horn

Hey there, Joe.  Thanks for chiming in.

So that I understand, projects that are republished under the latest update of Storyline 2, which previously had no issues, are now experiencing issues where the audio is cut off (sometimes randomly).  Does that sound right so far?  And to resolve it, you've found that opening the audio editor and closing, effectively re-encoding the audio seems to work.

Do you have a sample file that you wouldn't mind sharing so that we can have a look?  I realize you might have already adjusted them.  We can do some testing, though, and see if we can reproduce this issue.

sandy tranfaglia

I am having the same issue with SL2 when trying to publish - NO AUDIO. (we do have SL3 and 360 but I need to use SL2 for this project). Do I need to open a ticket or is there a solution for this issue now that it is 11 months later since the last post about this issue?

Thanks for any and all help!

Ashley Terwilliger

Hi Sandy,

I took a look at Norma's case since you had a similar issue, and it seems that repairing Storyline and confirming her files followed our best practices here resolved the problem she'd run into. Here are the steps to repair Storyline 2.

If you are still having difficulty after going through those, let me know! We'll want to see one of your .story files and know a bit more about your publishing process. So you're welcome to share that here in ELH or upload to our Support Engineers here.