Audio using multiple layers

Dear All,

Haven’t found this on the forum.
Is that possible to stop the audio of the other layer when another layer triggered / displayed?

-- I have 3 audio files, for base, Layer 1 and Layer 2.

-- Layer 1 and 2 will be displayed when the user will click on the buttons. User can select any layer button.

-- When any layer displayed, I can stop the base layer audio. But when the 1st layer audio is playing and user click the 2nd layer button, both audio are overlapping.

-- Also, I do not want to hide the content of the other layer.


Any thoughts?


Thanks,
Shailesh

20 Replies
Shailesh Mewada

Thanks for the file.

I have already tried that.

The option 'Hide other slide layers' is checked for the layers.

I do not want that option checked so that the content of the other layer do not hide.

If this is limitation, then there is only one workaround i.e. to create a separate layer for audio with the above option checked and show-hide with the other content layer. Yes, in that case audio synching will be an issue.

Shailesh Mewada

Shailesh Mewada said:

Thanks for the file.

I have already tried that.

The option 'Hide other slide layers' is checked for the layers.

I do not want that option checked so that the content of the other layer do not hide.

If this is limitation, then there is only one workaround i.e. to create a separate layer for audio with the above option checked and show-hide with the other content layer. Yes, in that case audio synching will be an issue.

Nope..that will also not work.
Rebecca Fleisch Cordeiro

Hi Shailesh,

Did you click the "pause the timeline of the base layer" checkbox ALSO on Layer 2? Because it seems this pauses the timeline for Layer 1. So if you click the properties icon (that little icon that looks like a gear) on Layer 2, and click the checkbox there, I think it may work. At least, it has for me.

Shailesh Mewada

Hi Rebecca,

I want to stop the audio of Layer 1 when Layer 2 displayed.

I am already pausing the base layer timeline on the layer properties. It is only stop the base layer audio but not the other layer audio.

Also I do not want to hide the content of the other layer, just need to stop the audio of that layer.

Thanks.

Rebecca Fleisch Cordeiro

Hi Shaliesh,

Hmm. For me, if I have a Base Layer, a Layer 1, and a Layer 2, all with audio, this is what works:

To pause the audio on the Base Layer

Click the gear icon on the right of the Layer 1 Properties tab. When the dialog box opens, click to check the "Pause timeline of base layer" checkbox. This pauses the audio on the base layer.

To pause the audio on Layer 1 (see image)

Click the gear icon on the right of the Layer 2 Properties tab. When the dialog box opens, click to check the "Pause timeline of base layer" checkbox. This pauses the audio on Layer 1. Does this not work for you?


Christine Hendrickson

Hi Michelle,

When you say "Audio Button" are you referring to the volume control button, or the icon in a slide that shows when you have audio in your project?

I believe you're referring to the volume control button, but I just want to make sure :) If you are, then you can actually disable that button through the player options. 

To disable the volume icon on your player, click on "Player". In the main "Features" section of the Player Properties, you'll see an option for "Volume". If you un-check this option, the volume icon will not longer appear on your player.

Let me know if you have any trouble with this, or any questions.

Thanks!

Julie Z

Shailesh Mewada said:

Finally found a workaround.

attached file.

I am not sure whether this is correct way but it is working.


Hi Shailesh!

I was so happy to find your scenario because it is the same problem I am facing.  However, I am having trouble implementing your workaround.  When you created the trigger on Layer 1, how did you select the Sound 2 file from Layer 2? When I try to select a sound file other than the one on the active layer, Storyline imports the file.  What am I missing?

Thank you!

Julie

Shailesh Mewada

Hi Julie,

Yes, it is correct that you will not get Sound 2 on layer 1.

It is simple and tricky:
-- On layer 1, stop sound 1 on Layer trigger
-- Now copy that trigger (right click on trigger) and paste it in layer 2 and delete Sound 1 trigger from layer 1
-- Similarly do it for other sounds/layers also

I hope this will help.

Let me know if there is anything.

Cheers,
Shailesh