Audio Won't Play on First Slide in Chrome

Greetings Folks:
When I view my elearning course in Chrome (created in Storyline 2), the audio on the first slide doesn't play. If I pause the slide and click to start again, the audio begins playing. If I let the first slide run, no music plays but when the slide advances to the next slide in the chapter (and for all subsequent slides), the sounds plays fine. A friend who uses Storyline 2 says he's also experiencing this problem. It appears to be a recent problem. I don't remember it being an issue a few months ago. I do publish all courses to web with HTML5 included in the output. Neither .mp3, .wav, nor even a video (.mp4) will play on the first slide of any course. When viewed via the Mobile Player on the iPad, all first slides play the music. This is only an issue with viewing courses on a Chrome browser. Seems as if it's a problem with a Chrome update. 

Can anyone offer insight on the issue? Sure would appreciate it.

38 Replies
Alyssa Gomez

Hi there Rod!

You're spot on -- Chrome recently changed their autoplay policy, and that policy affects courses that have audio on the first slide.

But have no fear! We added support for Google’s new audio policy in a recent update of Storyline 2, and we created a tool that lets you mass update existing Storyline 2 courses without republishing them. Check out this article for details!

Rod Machado

Greetings Alyssa:

Well, I did ensure that Storyline 2 was upgraded then I downloaded and ran the Articulate Update. All my programs were supposedly updated. When I click the “story.html” link, the first slide in my course plays its music just fine. However, the “story_html5.html” link, when clicked, didn’t play the music on any of my 15 courses. Instead, when it is clicked, I see a big "play button" on the player. When I click this, the program starts but the music still doesn't play (at least until I manually pause the timeline, then start it again. This really does seem like an issue with HTML5. Is there any way to work around this issue? I sure do appreciate any insight you might offer.
Sincerely,
Rod Machado

Peter Ward

Thanks, Leslie. Unfortunately, I'm not experiencing the behavior described in the documentation. I have several courses that have just been published in the last few weeks (some today), none of which are showing the play button that is described. Audio is not playing on the first slide of any course unless the user clicks pause and then play again using the button next to the seekbar.

I'm using the latest version of Studio 360 (5.20.16882.0). Please advise.

Leslie McKerchie

Thanks for sharing the additional details and your version Peter.

This is actually an issue we are looking into and I'll add this conversation to our report so that we can update you when we can.

In the meantime, Chrome 71 added a Setting to allow users to override the audio auto-play restriction:

  • Chrome > Settings > Content Settings > Sound > Allow > [ADD BUTTON] > Enter URL
Peter Ward

Thanks for confirming what I suspected, Ashley. Unfortunately, that's not a viable solution for our courses, since they'll be taken by potentially hundreds of different users in The Coca-Cola System. We really need this issue to be resolved by this coming Friday, January 11th. Otherwise, this is going to incur additional cost and delay launch, which will definitely be a strike against Articulate 360 as our go-to solution for eLearning. Please let me know as soon as this issue has been resolved. Thank you in advance for your continued assistance.

Katie (Gokhshteyn) Riggio

Hello, Miriam. Thanks for checking in, and I'm sorry this bug is affecting your projects.

This isn't fixed in Storyline 3 yet, but we'll update you here as well as the Storyline 3 Version History page as soon as it's ready. In the meantime, let us know if Ashley's approaches could work.

If we can be of any other help, please don't hesitate to let us know!

Katie (Gokhshteyn) Riggio

Hi there, folks!

To follow up on my last post: Update 6 for Storyline 3 is now live; check out all the enhanced features and fixes here!

You'll find that we added support for the latest autoplay changes in Chrome 71+, so learners see a play button when they launch or resume a course that has audio or video on the first slide.

Click here to download the latest Storyline 3 update. Let us know what you think!

Chris Sloyer

Hi Crystal!

Thanks for the quick response! Yes, I'm working with Storyline 360 :).  Our courses start with a brief title slide (with audio) that auto-advances to slide 2. The audio seems to kick in on slide 3 (which is good) or if the learner clicks somewhere on slide 1 or 2, clicks the speaker icon, or leaves the course and restarts it.  The frustrating thing is that a couple of months ago I found a work around on in this community (YES!!), which as to add a new autoplay slide to the start of the course, with a very short duration - but unfortunately that workaround no longer seems to work in the LMS.  I'm tempted to try to use the fix discussed in this thread: https://articulate.com/support/article/Storyline-and-Studio-HTML5-Audio-Won-t-Play-in-Google-Chrome-66-and-Later

thanks again!

Chris

 

Ashley Terwilliger

Hi Chris,

As modern browsers continue to look at preventing unwanted auto-play of media, more and more of those workarounds are no longer functioning as expected. The simple method is to ensure that the learners interact with some element of the slide/course prior to any audio/video that they'd need to have play automatically.

The link you shared is a notation of this change in browsers like Chrome and Safari, and if you're publishing with the latest update of Storyline, Studio, etc. and have any media set to autoplay on the first slide, your learners will see that play button to initiate it.

Let us know if you need anything else, and we'll keep you and other folks posted on that bug Crystal mentioned.