Automatic layer triggers

Oct 18, 2013


I have a question about the layer triggers in Storyline.

The following triggers always appear automatically within the layers correct, incorrect and try again:

- jump to next slide when timeline ends

- hide layer (this layer) when timeline ends

For the project I'm making with Storyline I want children to press a button themselves to jump to the next slide, so they can take as much time as needed with the feedback on the layer.

Is this some kind of setting in Storyline and if this is the case, how can I change it? Because at the moment, I'm deleting all layer triggers by hand in every slide. It would be very handy if this could be taken care of automatically

Thanks in advance!


38 Replies
Crystal Horn

Hi there, Ann.  I hear your frustration.  I just want to make sure I'm on the same page with you, since the trigger setup is a little different in Storyline 360.  Currently, the default feedback layout triggers for the Continue button are to Hide this layer and to Jump to next slide, when the user clicks the Continue button.

It sounds like the issue is that you're customizing what happens when they click Continue, but the triggers keep reverting.  Is that correct?  Tell me a bit more about your workflow. 

  • Are you updating the branching options in Form View? 
  • Updating the triggers on the slide layer in Slide View?
  • Adding triggers to a feedback master layout?
Ann Cecil Evora

Hi Crystal, 

I am Updating the triggers on the slide layer in Slide View. I tried to save time by setting up one slide (removing the triggers to hide layer and jump to the next slide) and then just duplicating it so I don't have to delete them again. But it didn't work. Everytime I made changes to the questions in form view the triggers keep coming back so my resolution is to delete them one by one in a 50 item exam. :(

Crystal Horn

Thanks for that detail, Ann.  I'm going to update our documentation of this issue with your experience and the continued impact.

We are seeing some issues with default feedback layer elements "sticking around" even when you're using a custom feedback master layout.  This might be a workaround that helps you:

  • Delete any text from the Form View feedback section.
  • Design your feedback master layout.
  • Manually add Correct and Incorrect layers, and select your designed layout.
  • If that setup works, duplicate the slide and change the question and answer text for subsequent slides.  Don't use the feedback panel in Form View.

I'll let you know if we make some changes to this behavior!

This discussion is closed. You can start a new discussion or contact Articulate Support.