"Automatic" Triggers added by Storyline in Freeform Drag and Drop Exercise

Hello everyone here in the community, 

I might have a problem with regards to Freeform Drag and Drop Exercises within Storyline 1. (I currently use Version 5: 1401.2415 | Did not Update, cause I was working a longer time on a project, and was afraid that an Update might have an impact on my project).

I say "might" because I have found a solution for the problem, but this solution is not satisfactory. 

Here's the issue: I created a Freeform Drag and Drop Exercise. The user has 2 attempts for the exercise, that's why we of course have 3 Feedback layers. Apart from screentext on the three layers, I put a button on each FB layer: 

1. Try again layer: Button "Try again" with Trigger: Hide layer when user clicks 

2. Incorrect + Correct layer: Button "Show solution" with Trigger: Jump to next slide when user clicks 

Did all work well, but somehow, Storyline put two additional triggers on each Feedback layers:

First trigger: Hide layer (this layer) when timeline ends 

Second trigger: Jump to next slide when the timeline ends 

After I recognised these triggers, I started deleting them, saved my project, republished it. Worked well for a while, but then, these triggers reappeared for unknown reasons. I could not yet figure out, why these two triggers keep appearing even if I delete them. 

The problem is half solved, cause the whole exercise works fine when you "say" both triggers: 

1. Hide layer (unassigned)

2. Jump to slide (unassigned)

I'm glad that it works this way, but I now want to ask here: 

Does anybody know another reason / solution for the problem mentioned? 

I have attached a screenshot. Thanks in advance for your replies.

 

Best regards and Greetings from Germany,

 

René 

 

6 Replies
Emily Ruby

Hello Rene, and welcome to the community!

The default triggers associated with the incorrect and correct feedback continue button are Hide layer when user clicks, and jump to slide when  user clicks:

I have not heard of the "when timeline ends" being added as a default. Please confirm that you are working locally as described here. Also, is this the first time you have seen this happen? You may want to follow the steps listed here if you continue to get the same results.

René Müller

Good morning and thanks for the quick reply. 

@Emily: I checked the links you provided. That was helpful, cause I was indeed not working on my local hard disc. This might be the reason for Storyline's "strange" behaviour. I will keep you informed. 

One comment about the triggers: They are inserted as layer triggers and not as object triggers (see screenshot attached in my first post). 

 

Greetings

 

René

John Ruiz

I've been fighting with these same phantom triggers (when timeline ends) that show up.  I noticed that they reappear if I edit the question then save and close the question window.

For now, I just remember that if I ever edit the question, I have to go back to my feedback layers and delete those triggers.