Bookmarking issues

Hi, 

Has anyone had experience with an odd bookmarking issue as follows?

I've built a number of courses that experience bookmarking issues only after the learner has completed the course (course completion is by trigger when reaching the final slide). If a learner exits the course before completion, bookmarking is fine. I've tested in SCORM cloud to confirm this. The cmi.suspend_data from the debug log is around 3,800 characters. Publishing in SCORM 2004 doesn't seem to fix the issue. Fortunately, we are able to put it up since it's a relatively minor issue (very few learners return to the course after completion). 

Regards,

 

Nick

3 Replies
Lejan Ocampo

Hey Nick,

That is pretty odd indeed. Just a few clarifications here, what happens when they re-open the course after completion? Does it go back to the questions on a particular slide in the course?

Are you using a particular LMS? You also mentioned you've tested it in SCORM cloud to confirm it, do you mean the bookmarking works fine after completion when tested in SCORM cloud?

Hopefully, these pieces of information could help us isolate the problem and resolve this issue.

Nick Tchan

Hi, 

No, sorry I wasn't clear about SCORM cloud. The issue occurs in SCORM cloud as well. Bookmarking is fine if you exit before course completion, but it doesn't work if you complete the unit.

I don't directly control the LMS, so I'd have to ask them to find out what type of LMS it is...

It doesn't appear to be consistent, but I'll to retry it to confirm this. Watch this space and I'll get back to you. 

Many thanks for taking the time to reply, 

Regards,

Nick