Bug report - Storyline 2 - HTML5 - Button on slide layer blocks clickable object on base layer from been clicked after layer has been hidden.

My slides base layer has a grouped object that has an onclick show layer trigger which displays another slide layer when clicked.

This slide layer contains a storyline button which has an onclick hide layer trigger to hide this layer.

The trouble is that even after this layer has been hidden, the clickable area of the button remains thus blocking clicks to objects in the same position on the base layer.

See published file here: http://rlowry.github.io/testing/test_story_1/story_html5.html

You can replicate by clicking the group that contains the text "Click me" which shows a layer and then by clicking the close button and holding your mouse in the same position. You'll find you cannot click the group to reopen the layer.

This happens in both the latest version of Chrome and Firefox when viewing the HTML5 published output.

I've replicated this bug in multiple story files to rule out the possibility of an issue with an individual project.

Has anybody else experienced anything similar?

Update

I've found a simple workaround that I should have thought of trying before posting this. 

I've added another trigger to the Close button which disables the button just before the slide layer is hidden. I've also added a layer trigger which changes the state of the button to normal when the slide layer timeline starts. Now the button on the hidden layer does not block clicks to base layer objects.

See attached file Test_fixed.story for an example of the workaround.

Hopefully this will help anybody else that runs into the same issue.

(Kudos to Articulate support who also suggested the same fix).

12 Replies
Ryan Lowry

Ok, I've found a workaround. I change the state of the close button to disabled when closing the slide layer and vice versa when the slide layer timeline starts. I seem to find myself constantly having to find workarounds for issues like this in Storyline. Thanks for your help Walt. I've updated my original post with details of the workaround.