can't get image to change states using Triggers

Hi, all. I can't figure out why I can't get all of multiple triggers to function on an image. I'm not sure if it has to do with trigger order or what, because I feel like I have tried every order there is. I have three triggers on an arrow image:

  1. Move a separate image group along a motion path when click arrow given condition that current state = "open" (which is initial state)
  2. Change state of arrow to "close" when click given condition that current state = "open"
  3. Change state of arrow to "open" when click if current state = "close"

If I put them in 1-2-3 order (like they are now), 1 and 2 work but not 3.

If I put them in 1-3-2 order, only 1 works.

If I put them in 2-1-3 order, 1 and 2 work, and 3 doesn't but also makes the group move on the motion path again.

If I put them in 2-3-1 order, only 1 works.

If I put them in 3-1-2 order, nothing happens.

If I put them in 3-2-1, only 2 works.

In essence, trigger 3 never works under any circumstances. I just don't get what's happening! Does this have anything to do with the motion path trigger? I haven't used that before, so that is the one variable in my otherwise intermediate abilities in using Storyline. Relying on the brain trust to help me through this conundrum... thx

4 Replies
Wendy Farmer

Hi Laurel

I've made a few changes - may or may not suit and you'll need to tweak positioning if you want to go with it.

I added your > to the group and saved as a picture. Then I changed it's direction to <  added that and saved as a second picture.

The first picture becomes your normal state, the state picture becomes the closed state.

I also added another motion path to reverse the direction when they click close and tweaked your triggers.

Hope it gives you some ideas.