Can't hear audio in published Storyline 2 - on some slides

Hello - I've got a deadline fast approaching, so I need help quick! I have a Storyline 2 file. When published, only some slides play the audio, others do not. I have looked everywhere for differences between the slides that DO play and those that do not, to no avail. I am developing for HTML5, but it does not seem to matter whether I'm viewing the published file in HTML5 or Flash -- the problem exists in both environments. Testing this on my local drive, not on a network drive, using latest version of Chrome. I've tried republishing older files -- no problem with those, they play as expected. So I think it's something with THIS file. I've attached a condensed file. The first slide and only one other slide play the audio. The rest don't. Can anyone help? Thank you! -- Brigitte

18 Replies
Brigitte Cahill

Well, I tried all of the above things, and the 'importing' did seem to fix it. BUT, I tried something just for the heck of it in my original, troublesome file: I did a Preview > entire project, viewed it in Preview mode, saved the file, and then 'Published' it. (I had previously only previewed parts of the file, never the whole thing.)  This somehow FIXED my original file! How strange is that? Anyway, it seems I've got a solution, one way or the other. Thanks for the help, folks! -- Brigitte

Ashley Terwilliger-Pollard

Hi Brigitte,

That certainly sounds like some holiday magic! But, I'd also want to confirm that you're working on local project files as detailed here and using the latest update of Storyline 2 Update 11. Not using the latest update means you're not taking advantage of the latest fixes and working off a network/shared drive is know to cause some odd or erratic behavior. 

Brigitte Cahill

Oh yes, for sure, to both. I don't ever work on the network, and had the latest Storyline  version installed. Incidentally, there were several slides in my project for which the audio WAS working, but for most slides, it was not. And that turned out to be the common denominator for this issue: all slides I had previewed at one time or another over the last couple of weeks had the audio working properly. The rest that I had not yet previewed were NOT playing the audio.  Although I hope no one else encounters this situation, this might be of help to someone down the road!

Darus Ng

Hello - I also have the same issue, except the solutions above do not work for me!

When I preview my scene and project in Storyline, everything appears and sounds perfectly. However, when I publish to HTML, 2 slides are missing their audio files. I have tried deleting/re-adding audio files, importing the slides into a new project, and still having this issue.

Please help!

Darus

Brigitte Cahill

Hi Darus -

Try: Save file. Then preview entire project, making sure it begins to run properly. Then save file again. Then publish, test.

One other thing that has worked for me - sometimes! - is to start the audio file just a half a second into the timeline. Then do all of the above and try publishing again...

Brigitte

Brett McAuliffe

Hi there,

Having the same issue on just a few slides. Have published other courses just fine, even an earlier version of the one i'm working on. I have saved as a different name/location, replaced the audio on the problematic slides and yet they still behave the same. I suspect it's an error with the publishing render. Other than having to reinstall the software (again) and repeating the above steps, are there any other solutions? 

Leslie McKerchie

Hi Brett,

Curious if the issue happens in any course you are working on or just this particular one?

If you cannot re-create the issue in a new course, I would advise to import the file into a new one and proceed.

If it's happening in any/all files, you should certainly conduct a repair of your software.

If you're still having difficulty, you can certainly work directly with a support engineer here since you mentioned having done some troubleshooting already.

Jerine Sebastian

This issue still occurs even on Storyline 360. I can't share my SL file outside the organization. But this is not the first time the issue is happening. I'm familiar with the issue for 4 years now. Still I don't see any resolution on this forum. Most people are trying something and it gets resolved. Seems like we need to rely on luck more than technical support. :(

Leslie McKerchie

Hi Jerine,

I just replied to a similar post here, but we would certainly like to help you out as well.

You are welcome to work directly with a support engineer here since you are unable to share your file here in the forums.

Otherwise, some additional details about the issue you are experiencing would help us get started in troubleshooting with you.