Cannot Get Text Boxes to Clear When Restarting a Scene

I posted this a couple years ago and never found an answer. I have a Question Bank with 10 questions, the Scene is used by multiple students (1st Grade spelling practice). I want the fill-in-the-blank text fields to clear after the 10 questions/slides are run though by one student, so the next student doesn't see any of the previous student's text entries.

I've tried attaching a "Restart course when the user clicks" trigger to a "Restart" button. That doesn't work. Earlier I tried adding a trigger to "Reset results <result slide> when the user clicks" to the result slide. That doesn't work. I tried adding a slide in the scene (prior to the Question Bank draw slide) that "Resets results  <result slide> when the timeline starts." That doesn't work.

What works is quitting the program and starting it all over...not a very elegant solution.

This dilemma frustrates me almost as much as NOT having the Backspace key work in a text entry field and NOT having the cursor automatically appear in the text box when the slide/question is displayed.

I'm trying to create a spelling game that doesn't require the teacher to always say, "click in the text box before you answer" and "ignore that old entry, type your own answer." :-(

Help?!?

17 Replies
Rebecca Fleisch Cordeiro

Hi Jonathan,

I just tried an approach with a 2-question question bank slide, based on your statement:
"I want the fill-in-the-blank text fields to clear after the 10 questions/slides are run though by one student, so the next student doesn't see any of the previous student's text entries."

So,

  • I created two fill-in-the-blank questions in the bank.
  • I set each of these question bank slides to "reset to initial state" (via the slide properties "gear" on the lower right of the slide).
  • I also added a new Slide trigger in each question slide, first trigger (at the top of the trigger list), that sets the TextEntry on that slide equal to blank when the timeline starts. So for my first question slide the variable is TextEntry and for my second question slide the variable is TextEntry1 (I didn't change the default names)

II created a 3rd slide that's just a Start over slide. I inserted a button called Start over that jumps back to the question bank slide

Seems to be working. Do you think it might work for what you're doing?

Jonathan Bacon

In your third bullet, I assume you mean the trigger is set to "Adjust variable > TextEntry1 > = Assignment > Variable = unassigned > When timeline starts" ??

I vaguely remembered trying to set each slide properties (using the "gear") to "reset to initial state" and I re-tried that just now and it doesn't work alone, so I'm adding the variables.

Paul Scarnegie

Just an FYI to all those attempting to reset text fields in quizzing questions. There appears to be a problem (ie. bug) with this approach of setting the text field variable to null or blank on slide start. The first run through the slide will correctly display the "type your text here" temporary text in the text field which then disappears upon clicking into the field. However, any further return visits to the same slide (regardless of reset to initial state options) will simply display the same text field now as "blank", that is empty. The temporary text "type your text here" is no longer displayed in that text field as an indictor to the user of where to actually enter their response. I've tried setting the text field to both "blank" as well as a null variable to no avail and have resigned to calling this a bug. The solution at this point is to have additional instructions on screen indicating to the participant where to actually enter their answer. Certainly not a best case scenario, but effective in at least erasing the responses from previous visits to the same slide.

Leslie McKerchie

Hi Jenny!

This thread is a bit dated and looks like most of the users were able to resolve the issue.

In addition to resetting, be sure that the slide is set to 'reset to initial state' as well.

In Paul's case, the text not showing up, "type your text here", is what was filed with our QA Team and I do not have an update to share regarding that.