Cannot save Storyline project Boolean System Threading error

“Articulate Storyline”  -when I attempt to save my project, I receive the following error:

“The project file could not be saved.  Method not found: ‘Boolean System. Threading. WaitHandle. WaitOne (System.TimeSpan)’.  Option to click “OK”

 I tried to save the project to my documents (received the error) and also tried to save to C Drive. 

I have downloaded the program again....and continue to receive the error when I attempt to save.

Any help would be appreciated.

Thanks.

14 Replies
Christine Hendrickson

Hi Julie and welcome to the community!

I'm sorry to hear about the trouble.

I'm not sure which method you used to reinstall, but I would recommend following the troubleshooting steps outlined in the following article, if you haven't already:

Unexpected or Erratic Behavior in Articulate Storyline

Let me know if you see any improvement.

Thanks!

Christine Hendrickson

Hi Catherine and welcome to the community!

Sorry to hear about the trouble. Just to confirm, you followed all of the steps outlined in the article I shared earlier, correct?

Make sure you follow those steps - a basic uninstall and reinstall may not resolve the issue.

Also, please make sure that you're working with a local installation of Storyline and local project files:

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).
  • Avoid using special characters, accents or symbols in your file names (this includes spaces and underscores).

Additional information regarding "Naming Files, Paths, and Namespaces" in Windows operating systems can be found in the following Microsoft article.

It may also help to check the Storyline System Requirements - make sure that you have a supported version of Windows and that your user profile on the machine has Administrative privileges. 

Articulate Support - System Requirements for Articulate Storyline

It may also help to right-click the Storyline shortcut and select "Run as administrator" when launching. Then, try saving a project file to see if you receive the same error. 

Let me know how it goes.

Thanks!

Ashley Terwilliger

Hi Maria and welcome to Heroes! 

Articulate software must be installed with administrative privileges. If you're not an administrator on your computer, please ask your IT staff for assistance in conducting the repair steps to uninstall and reinstall Storyline. On the other hand, Articulate software must be activated with a valid serial number by the person who will be using it. Administrative privileges are not necessary for activation.

maria Gonzalez

As Catherine and me have said, we already have the articulate installed and activated. The problem cames when we want to SAVE a project and the error is: “The project file could not be saved. Method not found: ‘Boolean System. Threading. WaitHandle. WaitOne (System.TimeSpan)’. Option to click “OK”

Ashley Terwilliger

Hi Maria,

I haven't seen that error before, and we've yet to here back from Catherine in regards to if she followed the steps Christine mentioned above. 

So just to confirm the following:

  • You're working with all local project files as described here, and adhering to the directory path limit of 260 characters and not including any special characters or symbols in your file name
  • You've installed Storyline as an administrator
  • You've conducted the repair steps shared by Christine above and outlined here

If you've checked into those, next I would suggest testing saving a new file to see if the behavior persists. If not, can you try importing your existing project into a new file to see if that resolves the behavior? 

If you're unable to save a new file as well, please conduct the steps outlined here for a deeper repair of Storyline. 

Please let us know how things are behaving after going through the steps above. 

Ashley Terwilliger

Hi Kevin and welcome to Heroes!

Sorry to hear that you're having the same issue, and I see that Jonathan replied to your Support case with the following information:

Actually, no one in the forums mentioned if they working on their project from their local C: drive. 

Are you saving and accessing your Storyline project directly from your local C: drive or from a USB or network drive? 

When creating, editing, or publishing a Storyline project, be sure you're working from your local hard drive (typically your C: drive). Working from a network drive or a USB drive can cause erratic behavior, such as file corruption, an inability to save changes you've made to your project, and loss of resources. 

Please review the following article for more information: 
http://articulate.com/support/kb_article.php?product=st1&id=cw6rhkr2xpxr  

Please feel free to let Jonathan or me know if you're working on local project files. Also, in your support case I saw you mentioned working on Parallels on your Mac, and I wanted to point out this article on best practices when working in Parallels.

Kevin Cassidy

Hi Ashley,

I responded to Jonathan today. 

I am accessing my project from my C: drive. I have also relegated the troubleshooting to my Windows Vista PC to take the Parallels variable out of play. I deactivated and moved my key over to my PC laptop before reloading and retesting a fresh reinstall to no avail. I tested a single slide project with just one word of text for the simplest environment to test, but with no success. I have followed all of the troubleshooting on this thread to date. I also installed the program as the Administrator.

The software is registered, the .NET framework is compatible, Flash Player is updated and still no luck.

I followed the Repair steps to repair the install in case that was the problem. Nothing has helped so far.

Hoping we can get this resolved.

Thanks

Kevin

Ashley Terwilliger

Hi Kevin,

Thanks for sharing the information here in regards to what you've already tested. I'm curious if you could share that one slide project to help us determine if it's a file specific issue and I'd like to see the error message in action. I did a general web search for that error message, and found this documentation within Microsoft, although I'm not clear on it's meaning or any troubleshooting steps so it wasn't incredibly helpful. 

You'll want to use the paperclip icon to post it here or you can reply to your case with Jonathan to share the file. 

Kevin Cassidy

Hi Ashley,

I have great news to share!

This error message is related to the .NET framework. Anyone missing .NET 3.5 SP1 will receive this message.

Just need to go here.

http://www.microsoft.com/en-us/download/details.aspx?id=22

Many thanks to Jonathan for the research on this!!

Hoping this resolves everyone else on this post.

Kevin

Ken Willis

That absolutely worked.   I am a brand new user to the community and had the same error message (Boolean thread, etc).  Looking it up on Google, you could see it was related to .NET somehow, not Articulate specifically.   That update solves the problem.   I am able to save my first Storybook file - after losing many good drafts before.   This is a great fix.