Cant get course to play in articulate mobile player

Hi! I want to open a Storyline course running on my LMS in the Articulate Mobile Player App, but when I launch the course I just see an advert telling me to download the free Articulate Mobile Player App. I already have the app installed, and I can't get past the screen, so I have no way to play the course. The course is published in SCROM 1.2 with HTML5 and the play in mobile app options selected.

11 Replies
Ali Goulet

Hi Rebecca,

Thanks for reaching out to us, I'm sorry you're having this issue! Apple made some changes to the way apps launch in iOS 9, so your Articulate Storyline 2 courses may not launch in the Articulate Mobile Player as you'd expect. We added support for iOS 9 in Update 7 for Storyline 2. Check out this article for details on how to update your Storyline software and your published courses. Let me know how that goes! :)

Becky Evens

Hi! I have updated to the latest version, and I can get the course to open now - but it doesn't play if I tap 'launch' - I have to press and hold over the button and select 'open in Articulate' to get the course to open in the App. That's not a problem for me now, as its just for me to add a quiz onto a set of stand alone iPads, but it could be an issue for the future if I need to make a course that could be taken by learners.

Thanks for your help!

Ali Goulet

Hi Rebecca,

Thanks for the update. 

As Michael mentioned, tracking for the AMP is only supported with Tin Can API.

If you publish for SCORM or AICC and you don't need to track users' progress or results, you may still be able to view content in the Articulate Mobile Player. Some learning management systems will allow it, while others will not. You'll need to test your content in your LMS environment to determine if your LMS will allow viewing SCORM or AICC content in the iPad app. This may be the reason you're seeing this issue. 

Tram Nguyen

Hi Ali,

I have the same problem of not being able to view Scorm lesson on ipad. I published the course in Scorm 2004 and left the AMP box unchecked. Is this the reason that the lesson doesn't play as expected from LMS on ipad? I test the course on Scorm Cloud and it plays ok. Only having problems when launching on ipad. 

Could you please advise me on how I should publish the course so that our learners can launch it  on Ipad and we also can track their progress from our LMS?

Attached herewith please find the file for your reference.

Thanks,

Tram. 

 

Ashley Terwilliger-Pollard

Hi Tram,

Thanks for sharing here. This looks like your published output, and I'd love to take a look at the original .story file and publish it to see what settings you used. 

Also, do you know what update of Storyline you're using? You mentioned it working at SCORM Cloud, did you also try that link from your iPad? Is it only within your LMS that it doesn't work? When you try to launch it on the iPad do you see an error message or just a blank screen? 

Tram Nguyen

Hi Ashley,

Thanks for getting back to me. 

I'm using Storyline 2. I did try the link on Scorm Cloud from my iPad air 2. The lesson didn't behave as I expected. I programmed the quiz in that lesson in the way that it shows correct answers after learners fail to try two times. However, when I tried it on my iPad, the lesson still launched but the drag and drop content  in the quiz is hidden and it didn't show correct answers after the 2 tries. 

Please find the working storyline file attached here.

Thanks,

Tram.

Ashley Terwilliger-Pollard

Hi Tram,

Thanks for sharing your file with me.

I see what you're describing about the items being hidden, that they appear below the main part of the course after animating in. I'll keep testing that part as I couldn't answer correctly or incorrectly without being able to drag them to the portion of the slide. 

I'll be back in touch after a bit more testing. 

Ashley Terwilliger-Pollard

Hi Tram, 

Thanks again for your patience while I tested it. 

Two things:

  • The grouped objects are what is causing the issue with the items appearing below the fold. I modified slide 2.6 as the first drag and drop to have the text on the actual object and then published it to upload to SCORM Cloud, and that version worked on my iPad. (I stripped it down to a few slides, but you can test that one here). 
  • I also noticed after the fact that your variable trigger is set to happen after the user has already left the slide. So that's why they'll see the try again over and over without getting the incorrect notice. You can rearrange the order for these, and I'd set the variable to adjust at the start of the "Try again" timeline vs. when they click on the button. 

Hope that helps and let me know if you run into anything else.