Changing button state using variable or state of another button not working

Mar 24, 2017


I have created 3 buttons to mimic playing video.  I want to change the state of the play button to hidden when the learner returns to the slide from the layer and make the state of the replay button normal.  The replay button is hidden at the beginning and it works.  The play button remains in the normal state.  I have tried change state of Play Refresh to Hidden when refresh (variable) changes.  I have also tried change state of Play Refresh to Hidden when state of Replay Refresh is Normal.  Also, I have a checkmark that I want to appear when the replay button is normal, but the state doesn't change until I click the replay icon on the seekbar. 

Any ideas?

4 Replies
Walt Hamilton

The checkmark will not change, because the change is initiated by the timeline start. When you go to a layer, you are on the same slide, so the timeline doesn't restart. Change it to fire "when refresh changes", and you won't even need the condition.

The layer setting to hide objects on the base layer is the problem with the Play button. While the layer is visible, the refresh variable changes, which makes the Replay button visible. That changes the Play button to hidden. (By the way, I would set both of those actions to be initiated by the variable changing, because I have had trouble with "When state is", but never with "When variable changes".)

Play button is now hidden, and when the layer closes, it sets all the hidden objects on the base to normal, including your button. Unselect the option to hide objects on the base and it will work. The layer covers the base layer, so the user can't see the base layer, anyway.

Indrani Sen


I did not experience this problem before.   When I revisit Main Menu page, after visiting respective modules/scenes, I do not see the button change into visited state.

For the orange button, the visited state is shown as I have set it up as the Selected mode, but for the violet, green and blue buttons, this does not work,

 I cannot figure out the problem. E-Learning heroes-please could you look at the source file?  It is fairly large.  I will be happy to upload into a secured site.  Thanks

This discussion is closed. You can start a new discussion or contact Articulate Support.